Kodi won't index specific show > Attempt to use invalid handle

Hi, I’m running Core Elec 19.5 on an C4, and I have an odd issue with 1 specific show that simply won’t properly index on Kodi.

The show in question is Reacher, I’ve recently added this show and Sonarr has picked up the episodes, placed them in the NAS share that CoreElec is also watching.

Via the core elec file browers, I can see the files there. I have SSHed into the C4 and verified that the permissions are the same (or better) than many other shows on that share that work without issue.

Additionally, after I tried to add Reacher, at least 1 more, newer show was added, downloaded and shows up in Kodi without issue or any manual fiddling.

Log: http://ix.io/4F00

Interesting bits:

VideoInfoScanner: Rescanning dir 'nfs://<snip>/mnt/vol1/Series/Reacher/'
ERROR <general>: GetDirectory - Error getting
WARNING <general>: Attempt to use invalid handle 1
INFO <general>: CPythonInvoker(1, /storage/.kodi/addons/metadata.tvshows.themoviedb.org.python/main.py): script successfully run

The files themselves aren’t anything I haven’t seen before as far as I am aware, standard fare x264 mkv, and they play as expected from a PC from the same shared NAS directory.
Additionally, via the Kodi file browser, I can see, and play the raw video files.

So far I’ve tried:

  • Matching access rights and permissions with other series that don’t have issues
  • Deleting the entire Reacher folder, doing a clean DB in Kodi and letting Sonarr re-create and fill
  • SSH into Kodi to triple check access rights
  • SSH into Kodi, mount the network share to a temp folder and check access rights
  • Double checked the files were copied and not merely symlinked

I’m at wits end at this one, but wouldn’t be surprised if theres some pebcak going on.

Thanks in advance for whomever takes the time to glance at this <3

edit: Updated to 20.2, issue still persists.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.