Kudos & a minor glitch

I just today downloaded and installed 8.95.3 (for plain S905) onto a microSDHC card which I then booted my old BeeLink Mini MX III from.

I bought the Beelink a year or two ago in the vague hope that OpenELEC would someday evolve & stablize enough to allow me to replace my old & bulky x86 HTPC with this tiny Beelink box. And I did try running one of kszaq’s much earlier releases on the Beelink some long time ago, but at that time there were still too many open issues, so I just put the Beelink on the shelf where it has been ever since. Today, I took it back down off the shelf and gave it another go with CoreELEC.

I have to say that I’m impressed. Everything, and I mean everything just worked, leaving me only one very tiny nit to pick. (See below.) And it’s not like I didn’t run CoreELEC through its paces. I did. I tried every different flavor of video file I have, and that’s a lot. Everything played just perfectly, including the 70mbps H.264 “jellyfish” demo, the 50Mbps HEVC “jellyfish” demo (the 70Mbps HEVC demo file was a little too much for the hardware, it seems), both MPEG4/AVC and VC-1 blue ray rips, and also all sorts of other files, including WMV1, WMV2, WMV3, MPEG4/ASP, and of course MPEG4/AVC. All this stuff worked perfectly, including even TrueHD audio passthrough to my receiver (from one of my BlueRay rips) and I was pleased to see that somebody somewhere finally got around to fixing the nit that used to make it an unintutive pain in the ass to replace Estuary with Confluence.

In short, this looks like a home run, and my kudos to everyone involved.

I do have just a couple of quite small nits to pick however.

First, unlike on my more powerful x86 HTPC, there is a noticable lag of about 1.5 seconds, each time I use the skip forward or skip back buttons while watching any kind of video. (There is zero apparent lag when these same operations are performed on my trusty old x86 HTPC running an ancient version of OpenELEC.)
I’ll file a formal bug report on this, if anyone says I should, but for now I’m just noting it here, and kinda vaguely hoping that someone will fix it. (I don’t know if this is even a CoreELEC specific thing. Maybe its a Kodi issue.) If this could get fixed then I could and would finally put my old x86 HTPC out to pasture and replace it with the Beelink. (I like to skip over the boring parts in all of the tons of DVD movie rips I’ve got, and this laggy behavior is just annoying.)

Second, under Confluence at least (I didn’t check Estuuary) pressing ‘o’ while playing a video still shows what’s going on but sadly, it seems that i no longer shows counts of the dropped and/or skipped frames. What’s up with that? This is useful info and now it has vanished??

That’s my only two nits. Like I say, other than these very minor things, 8.95.3 seems quite perfect, at least based on my testing.

The “o” issue is simply reduced functionality within Kodi - so out of the hands of Coreelec.

You can try upping the governor to “performance” to see if it solves your laggy issue. You need to modify your your startup file. At the same time you can overclock your GPU. However both of these mods can run your CPU hot and cause crashes - most of these boxes are inadequately cooled.

There is not an “autostart.sh” present in Coreelec so you have to create one with a plain text editor and then save it in your .config folder. This is a guide to how to do it:


However I have always had to change the permissions on mine to get it to work involves running :

chmod +x /storage/.config/autostart.sh

Add this line to set the governor

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor;

Add this line to overclock:

echo 5 > /sys/class/mpgpu/cur_freq;


1 Like

I’ll only mention as a possibility regarding the 1.5 second lag when skipping, to make sure you have considered whether the lag is caused by remote control lag? Not sure how you would check that: Maybe, when you click skip, does the UI show an immediate visual response, and then takes 1.5 seconds to actually perform the skip?

The o information has been moved, and now you can get to it by pressing ctrl+shift+o. I find it annoying, but it’s a Kodi change, not ours.

1 Like

I simply set it to “p” key with Keymap Editor

Thanks for all the replies folks. I’ll definitely gives Shoog’s suggestion regarding performance a try, but not the overclocking part. (There’s fundamentally no ventillation on these boxes, so I am understandably wary of doing that part.) Just curious – Why would performance not be the default out-of-the-box mode for CoreELEC?

In response to nd299, the lag is definitely not coming from the remote, as I was using the exact same remote both for the Beelink and on my older x86 HTPC.

Thanks also to TheCoolest for letting me know how to get the extended ‘o’ info back again. I understand (now) that this was/is an upstream change and thus not really something that is specific to CoreELEC.

The default is ondemand which ramps up CPU speed when needed. Performance will give more zippy experience (though how much is debatable) at the cost of higher temps because the CPUs are run at full clock speed all the time.

I have the same box, I decided I didn’t want android, so just installedtointernal I have to say I didn’t notice very much improvement. some people say it is quicker installing to internal, but beware, if you want to go back to android you will need to reinstall the origianl firmware.

I also have a Celeron NUC, I don’t think there is a noticeable difference between the two.

You didn’t mention, which Kodi version is installed on your x86 device.
I really think, what you’re seeing here is a feature and not a bug.

In Krypton the “skip steps” feature was introduced.
With it you can increase the skip time by pressing the skip button several times in a short time (e.g. first press: 10 seconds / second press: 30 seconds / …).
For this function it is necessary, that Kodi waits for your next button press before actually jump back or forward.

You can configure this feature in “Settings > Player > Videos” including the following options:

  • skip steps (which steps should be provided when pressing the skip button multiple times)
  • skip delay (how long should Kodi wait for another button press before performing the skip)

You can even completely deactivate this feature by setting the “skip delay” to “none”.
Without a skip delay your Beelink box should skip as fast as your x86 one (just tested it on my box).

1 Like

I’m too cautious to install to internal flash, so I’m just running from the microSDHC card.

In reply to relkai’s points, after some additional experimentation, I have to say that while I agree with the notion that this unfortunate (and very evident) skip +/- lag time issue probably does have something to do with this new Kodi “feature” my test results do not agree with relkai’s, and I do believe that this is most probably a CoreELEC-specific bug.

I tried relkai’s suggestion of setting skip delay to “None”, changing it from its default setting of 750ms, but this made no difference, and the 1.5 second lag associated with any skip +/- was still present for me. To be through, I also downloaded and installed the latest LibreELEC beta that I could find (8.95.005) onto my x86 HTPC and then checked for this skip lag also on the x86. On the x86 there was no such lag, regardless of the Skip Delay menu setting.

While doing these tests, I did notice one very interesting thing however. When skipping forward or back on my s905 box running CoreELEC 8.95.006, the jump to the new location in the video always happened in the blink of an eye, i.e. the first frame of the skipped-to point in the video became visible essentially instantaneously, and only after this frame was already on the screen did the approximately 1.5 second lag occur, with the frame in question just displayed statically on the screen with no audio, before playback resumed.

The bottom line is that relkai may be right, and this skip lag may relate in some way to this new Kodi feature he mentioned, but it is not present on x86 with a similar vintage of LibreELEC and it is present on my Beelink Mini MX III regardless of how I set Skip Delay in the menus.

I hope that someone can reproduce this issue, and then maybe it can get fixed.

P.S. While experimenting, I also found a number of other issues, but I’ll start a separate thread to report on those.

Sorry. I neglected to add that I also checked to see if this skip lag problem is/was present in the version of Kodi that shipped with this box (Beelink Mini MX III) originally. It isn’t. so this is effectively a regression relative to earlier releases.

(This box shipped originally with Android 5.1.1 and the manufacturer has issued no new updates at all since the box was produced, as far as I can tell. The original “stock” installed version of Kodi was 16.0/Jarvis. As noted above, this does not exhibit the skip-lag problem.)