Latest nightly - Strange video slowdowns?

Yes ill try, its weird though as it can be random.

Having the same problem. Appears like mentioned randomly about twice in one movie.

7.1 4k hdr output to avr

Just started watching the walking dead season 10, its happened 2 or 3 times in the first 3 episodes. Never ever had this before, used to be as smooth as butter, turned of passthrough and still the same so its not that.

I managed to video it but had to do it quickly, its 150mb, hope this helps.

DAMN WEIRD!!!

Ok im fed up now, its like every 5 to 10 mins, whats going on. Changed to standard skin, still does it.

Rule that out.

I’m having a very similar, if not the same problem, using the default skin.

My logs: http://ix.io/2e2C
Mediainfo for the file: http://paste.ubuntu.com/p/TwBnG5W5kS/

The problem is that when the video changes from one scene to another, past one of the chapter markers, it starts dropping frames terribly. If I restart playback from a point AFTER that chapter marker, it plays fine.

In the log files, I believe that the problem starts around the line: ‘2020-03-11 20:10:48.783 T:3227091840 DEBUG: CPtsTracker: pattern lost on diff -803092911.000000, number of losses 2’

Before that point, the ttd values are ~ +270ms. After that point, the ttd values are now ~ -802836ms, a very strange value.

It sounds like my issue is related to this: Odroid N2 test builds

From what I can tell, it hasn’t been resolved yet.

Bugger might have to go back to stable then, cant be having this hassle.

Nope not resolved, sure the number one aspect in any build is playback actually works, if that doesnt the everything else it redundant?

Can anyone tell me please your SoC revision?
By SSH: cat /proc/cpuinfo | grep Serial
Or in Kodi->Settings->system information (somewhere)

Mine says rev a

Hi, my:
Amlogic S905X3 rev c
Serial: 2b0c10000124180000113334504d5050

I’m not sure if what I’m witnessing is the same thing.
I’m using vim3 and noticed usually at the beginning of videos there are a few short occasions of slowdowns (1-3 times maybe) and then it plays fine throughout. It’s maybe a second or less at a time.

Looks like you got a model with Turbo Lag :wink:

My N2 behaves like an electric super car :slight_smile:

:stuck_out_tongue:
Maybe it’s a slight network buffer issue. It only happens at around the beginning and is very brief.

Nope mine happens all the way through have to keep rewinding the video a few steps.

Never had it before.

@sramek76, do you have same issue on this box?
Or it’s just an output of command?

Just tried the dev issued by P, had slowdown within the first 2 mins, i just dont understand it, never had a single issue before.

Think i might bring in another box and test it.

You are not alone.

I have had the same issues with my S905X2 since the new kernel was implemented.

It is completely random and happens with both X264 and X265 files, although I have seen more instances with X264. The same content played when using stable build works perfectly.

The symptoms can also range from slowing down for a few seconds before resuming correctly to having to stop and start the playback to get back to normal. On some occasions skipping back and forward again can correct the issue but not always.

I’ve had all logging turned on and when it has happened, looked to see if there is any record of change in activity but there has never been anything shown for the noted times.

Recently there was one nightly where I went about 7 hours of varied playback before it started again and it can also occur once in a video to multiple times on another playback of the same video file.

There is also no occurrence of the issue on the nightlies for my S912, so it is definitely related to the new kernel in some way.

The next step for me is to try a completely fresh install with no addons etc installed just to rule out any possible conflict with something that may be running in the background due to other installations.

Your description is dead on, im gonna bring my other box in that is still on latest stable and test that, see what happens.

We have watched a lot of videos in the last few weeks, my wife Jill in the bedroom using S905X box me watching in the living room using N2.
720p, 1080p, UHD, UHD HDR files are stored on NAS.
Wired GB network
No slowdowns, no dropouts, nothing
Toughest test with the video Gemini Man -> UHD.HDR@60Hz
A very bad film in terms of content, but perfect for testing

We hear about slow downs only with Amlogic-ng, nightly. There was a huge Linux kernel bump from Amlogic since last stable. No tests are needed by 9.2.1 stable or Amlogic(not ng) devices as it is not comparable to nightly. The changes are too much.

What we see(I never have seen it here)/read it happen by using a AVR/Soundbar/passthrough/h264/h265/AAC setup. The error happens randomly so it looks like a threading issue. This is very hard to find and even impossible when no developer can reproduce it locally.

But we are still reading/searching the reason for this and hopefully solve it asap.
I will create a new test image today as we need to try everything if it may help or not.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice