Leaking dns with vpn

I have coreelec 19.5 installed on an n2+. I have downloaded and configured the VPN manager openvpn with my nordvpn credentials using the wizard. It says I’m connected but when I run dns leak test I get “your dns may be leaking”. When I disconnect the dns it says “your dns is not leaking” what am I doing wrong here?? Let me know if more info is needed. Thanks in advance.

It will be worth Googling ‘openvpn your dns may be leaking’. as there are many threads about it and potential solutions.

Thanks for the info. I have actually already read that article and have been googling like crazy for the past few weeks. Still I have found nothing to help. I am curious if I’m getting a false positive for the leak. It’s just really strange that when I’m disconnected from the VPN it say my dns is NOT leaking but when I am connected it says it MAY be leaking. Plus I don’t know how leak protection works with nord. Am I really protected by the man behind the curtain? Thanks again for the responses. EDIT: I’ve also seen somebody say the VPN manager for ovpn doesn’t play well with nord. I’ve tried using the nordsetup but I get a dependency error for it on 19.5.

In the context above, we use may to refer to weak possibility in the present and future:

The economy may go up or down in the next year. (I think both are possible, the economy going up or the economy going down. I am not making either one a strong possibility.)

I think I may go to the doctor today and try to get some antibiotics. (I am not very sure yet if I will go to the doctor.)

My advice, use common sense.

Have you tried zomboided vpn manager?

That is the VPN manager that I’m using. I’m gonna try loading an earlier version of coreelec as I’ve seen some add-ons don’t work with 19.5. Thanks again.

If you are using Zomboided VPN manager, it should be solid under CE.

I use same manager with a different VPN provider and I experience no DNS leaks.

Maybe try 1.1.1.1 as DNS Server and see if the issue persists?

Query	Progress...	Servers found

1	......		1
2	......		1
3	......		1
4	......		1
5	......		1
6	......		1

Server: unn-185-93-1-113.datapacket.com

I tried using 1.1.1.1, 8.8.8.8, as well as the nordvpn dns. I also Uninstalled the manager rebooted then installed again and still the same thing. Doing an extended dns test on dns leak does report back my isp, so I know it is leaking. Gonna do a clean install of an older version so I can use their client. It might help. My isp is currently having an outage so can’t really test that now. Thanks again.