LEDs on Homatics R 4K Box

Good evening,

I cannot seem to get LEDs working on Homatics R 4K Box using CoreElec. I have tried all the different versions of the Homatics LED Addon (Knight Rider Kit), but I cannot get them to work in any way. I have tried giving permission via SSH, use an autostart.sh script, etc. Is there something I am missing? I am using the generic image for Amlogic devices with 4GB and 1GB.

Best wishes,

You don’t have to use anything special: just install Homatics Leds addon from CoreELEC repository.

I did. I tried multiple times to no avail. I can’t get the LEDs to do anything.


Maybe you need the right DTB ?
Don’t know if it helps, but you should use the sc2xxxx_sei_280 file … Don’t know if it named correctly but something like this.

The add-on should work out of the box.

And it’s only working on Box R 4k plus …

1 Like

I just did a fresh install and used sc2_s905x4_4g_1gbit as DTB (the generic one), as usual. I had no Idea sei_280 was for Homatics. Will use that one this afternoon and probably fix the issue. Thanks.

Can’t you read what was written above?

sc2_s905x4_sei_smb_280.dtb exact

See my reply. Never even noticed the sei_280 one. Thank your for your friendly reply.

Then you are using wrong image. And because you never posted what you use or posted any log everything is just a guess.

1 Like

I said that in an earlier reply. Anyway, great to know which one is actually for Homatics. That’ll do it.

Working great, of course. Can’t believe I wasn’t aware all this time. Big thanks.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.