LibreELEC to CoreELEC questions

currently using Minix Neo U1 with LibreELEC 8 + Kodi 17.6 (booting from SD card).
Quite happy except refresh rate switching stops working from time to time – after hard reset it works OK.
I would like to test new CoreELEC 9 with Kodi Leia, just to be sure I will do it properly:

  1. Flashing proper CoreELEC image and tree file to new SD card
  2. Backup my Kodi 17.6 settings to some external device (usb stick, NAS server…).
  3. Removing SD card (with LibreELEC) from Minix, inserting new one with, rebooting.
  4. Importing Kodi settings, testing…

My questions are:
a. Is above process correct ?
b. Can I use USB stick instead of SD card for CoreELEC (just for testing, I understand it will be probably slower) ?
c. If I decide I want to come back to LibreELEC, I just put back my original SD card to Minix and everything will be there as before ?
d. I keep reading about something called Whitelist (available resolutions list), but I guess it’s just CoreELEC thing right ? Can’t find it in LibreELEC.

Thanx a lot

Just follow the installation guide on CoreELEC’s main page:

Your LE data won’t be affected as you only use the new SD/USB for storage which have CE on it. I highly recommend you to install CE with Kodi 18 over LE Kodi 17 as there are huge improvement (Kodi v18 (Leia) FAQ) and much better support from the CE devs as they mainly focus on AMLogic boxes.

I advice you to not backup settings as it’s better to change the settings you want from default for Kodi 18. Whitelist was implemented in Kodi 18 and that’s why you have never encountered it before. Just ignore it if you don’t have any problems from playback with specific resolutions

Thanx for reply,
I am just trying to do it, using Rufus software. Problem is, once I burn image file to USB flashdisk, I can’t open it anymore in Windows 10 to copy proper device tree. I can see USB disk but is not accessible.
Did the same with SD card, burning finished 100%. Can’t even see it in Win10 once I plug it in :-(.

Take a closer look.
After burning the CE image, you should have two partitions.
The first one (FAT32) is accessible on Windows for sure.

OK, I did it again, this time I actually unmounted USB stick from Win10 before I removed it and it’s working :slight_smile: My fault I guess. Currently importing my Kodi database, but another problem - my Logitech Harmony infrared remote is not working. I programmed it from original Minix Neo U1 remote, not sure why is that.
Edit: Found thread on this forum about IR remotes setup, have to check it later. So far frame rate switching working fine, all testing files very smooth. If I solve my IR remote, I might switch to CoreELEC for good :slight_smile:

Hey there.
What exactly did you do to have access to the SD card / USB stick? I always go to “safely remove hardware and eject media” before I unplug my sd card reader, but it does not change anything in my case. The CoreElec card is not accessible.
I have tried with two different SD cards and two different SD Card Readers.
So, when I insert my CoreElec sd card with my card reader to a USB port of my Windows PC, it prompts me to format it (as it is unreadable) and I was kind of worried with that.

p.s. I am able to access the card via SSH (filezilla) and via Windows explorer as a network item.

I just unplugged (unmount first) SD card/USB stick and put it back. Tried with 2 SD cards and 1 stick and worked properly. “Safely remove hardware” did the trick for me. Did you wait long enough for Rufus to finish burning process ? Even after status bar at 100%, I still waited about 10 seconds more until the “start” button on bottom right corner changed status. You can try that. My Logitech Harmony 650 also working fine (used microsoft media center profile). Looks like only problem left is long press of OK button not working.

Yeah, thanks.
It seems my Windows (10) has an issue. Probably mainboard / USB drivers issues.
On a Win 7 laptop I have the sd card is accessible.