LibreSpot not working anymore (308.0 KB)

not for me, installed it, installed latest LibreSpot Update, nothing works. I see, there is no settings anymore under \…\Userdata\addon_data\service.librespot
Could this be a problem?

In older Version I had to put Login Informations there

I think your whole install is broken, perhaps you manually upgraded from 19 to 20 and didn’t do it cleanly. There are many error in you logs for unsupported repos too.

[ 3.050933@3]- systemd[1]: service.librespot.service: Failed to open /storage/.config/system.d/service.librespot.service: No such file or directory

Maybe try a fresh install.

did (with keeping data) it, but librespot is still not working (80.0 KB)

Try nightly as there is a new librespot update

I can confirm that the same problem persists on my system (Odroid N2) with CE version 20.3-Nexus_nightly_20230805 and Librespot add-on version 20.3.2

Below is the associated debug log

kodi.log (84.9 KB)

I want to add that mine was originally a completely fresh install of stable release 20.2, which didn’t work, after which I updated manually to the nightly, which still doesn’t work.

Any way I can help? I’m not a dev but I can try to test if needed

We are also not the dev of this addon. So you might search the author on GitHub.

Can someone try this?

It should be done from addon itself but from the log above I don’t see it in action. Maybe this ^^^^ could help.

1 Like

It works! Thank you a lot.

Before this I also tried downgrading to CE 20.1 and Librespot 20.1.0, and it worked too, so this must be a bug starting from Librespot version ≥20.2.2

Thank you for trying out this.
Yes, you are correct: there was change made in addon to run this command automatically. I will fix it today when time permits. Then addon will then be working as before.

1 Like

The addon has been rebuild and pushed to addon repo. Anyone with issue can try to remove the installed addon and then install it again. If this would not work let me know.

Tried it today; it still does not work.

Here’s the debug log:
kodi.log (92.2 KB)

Forgot to mention this new addon will be available only for nightly build.

Anyway, here is zip for manual installation:

Or just use workaround above until next stable CE20 release.

Oh ok, I too forgot to mention that I’m staying on the 20.2 stable.

I’ll wait for the 20.3 stable release and I’ll test it again then.

Thank you again for the help.

1 Like

Thank you very much. Works again after deinstallation of librespot and new install.
20.3 latest nightyl

1 Like

I can confirm that it works also with my CoreELEC. Thank you :+1:t2:

Can other users confirm my observations? Got two:

  1. Advantage - new add-on while Spotify is paused keeps the session, the previous version dropped session after minute or two (like you would press stop on Kodi)
  2. Disadvantage - while listening, after the album is finished no new content is being played on the new add-on. On the old one some random similar songs were played.

I’m aware that this can be issue for add-on author, not CoreELEC developers, but I would like to know if you have similar observations

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.