LibreSpot not working anymore


Since my return from two week holidays LibreSpot is not working. Kodi is visible through the Spotify app on android, but when I try to push music to it it’s trying to connect, but it always fails.Yesterday I have even tried to return to default settings for CoreELEC and install only LibreSpot addon (using version 20.2.2 by Anton Voyl from CoreELEC repository) and the effect is the same.

I would like to mention, that there was an CoreELEC update when I started my box after my return (Saturday evening), and I have updated it at once. Unfortunately I haven’t checked the if it was working before the update, but maybe it is related?

In the logs I cannot find anything suspicious but here is the log:

Has anyone expierience similar problem? This addon is crucial for me.
Best regards

Is there a other user that is using succesfully the LibreSpot on his CoreELEC?
If there is someonte, that would like to test I can give him one of my Family profile for testing.

Any help would be appreciated


I can confirm that it doesn’t connect anymore. My situation is exactly like you described.
Anything I can do to help troubleshoot?

Have you upgraded CoreELEC lately? Is there a way to downgrade to previous build?

I have updated lately. I now downgraded to the previous version using the CoreElec settings widget to try if librespot works with that but no luck.

I’ll try one more earlier version tomorrow and let you know if anything changes.

Thank you for the info. The best would be if we could start it on current version though.

Hi @TK3D

Are you able to use the Librepot currently? Any progress with that

I tried all available CE-20 versions and also the final CE-19. Also tried disabling avahi and run it with arguments “–disable-discovery --username x --password x” as suggested by someone in another thread. Can’t get it to work unfortunately.

I have tried the previous version - 20.1, but could not access CoreELEC repository.

Do you think that anybody can help us with that?

I have exact the same problem on latest CoreELEC with latest Librespot AddOn on my Odroid C4.

Please tell us exactly your CoreELEC version or make a Kodi debug log.

I’m using CoreELEC Nexus 20.2

Please try to refresh the repo on your device. The CoreELEC addons repo 20.1/20.2 is normal accessible from here.

Archived addons can be found here:

In future they will be found here:

Thanks you. It works again with this one (20.1)

I have the same problem, but I dont get the solution

If I keep Coreelec 20.2 and install librespot 20.1.0, it doestn work. Should I go bacl to CoreElec 20.1?
Thanks, regards, Michael

You have

well it doesnt connect, like the other people here say, same problem. Mobile android app shows “connecting”, but nothing happens. Started with the CoreElec Update. Every other device in the network (AVR, Volumio an Raspberry) work perfectly, so it is not a problem of anything but Corelec’s librespot

Make one kodi DEBUG log.

Did you turn automatic updates off?

With latest ce-20 -ne nightly it works perfectly