Librespot not working in 19.2-rc3

Hi,

I am on CE 19.2-rc3 version and librespot cannot start because of this error:

*** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/blog/projects/avahi-compat.html>
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: DNSError(Unknown)', connect/src/discovery.rs:264:6
suspended sink 1
event panic 2/3
   0: 0xab3490d0 - <unknown>
   1: 0xab370e38 - <unknown>
   2: 0xab341e34 - <unknown>
   3: 0xab34b820 - <unknown>
   4: 0xab34b1c0 - <unknown>
   5: 0xab34bf0c - <unknown>
   6: 0xab34b9e4 - <unknown>
   7: 0xab349688 - <unknown>
   8: 0xab34b92c - <unknown>
   9: 0xaaf859d4 - <unknown>
  10: 0xaaf85aa8 - <unknown>                                                                                                  
  11: 0xab01e610 - <unknown>
  12: 0xaafa2a14 - <unknown>
  13: 0xaaf8fe98 - <unknown>
  14: 0xaafabfbc - <unknown>
  15: 0xab34c410 - <unknown>
  16: 0xaafa39e8 - main 
  17: 0xf6dedb64 - __libc_start_main
                       at /home/portisch/CE/CoreELEC/build.CoreELEC-Amlogic-ng.arm-19/build/glibc-2.32/csu/libc-start.c:314:16

I tried latest nightly 28.8. without change.

Is is only me or very little users use this addon so no one notice?

Thanks

We’ll check. This addon is kind of a pain. It floods your system with messages and errors. I gave up on it a long time ago.

You don’t have network when addon is started. Enable Wait for network under Coreelec settings, Network.

I have that enabled already. I have some samba mounts and TVheadend which connect to server on startup without issue.
This error is probably related to Avahi which is mDNS daemon and not to DNS servers on my LAN or internet.

Well, I tried installing on on nightly build and it is running.

You are right.
I did clean install same nightly on new sdcard, just installed librespot addon and it’s working.
Guess it’s something on my side then.
Thanks

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice