Live dash ffmpeg don´t play on CoreELEC

live stream dash mpd cannot be run with kodiprop ffmpegdirect in Coreelec 19.5 and 20

It works fine on Windows Kodi 19.5 and 20

Coreelec 19.5.log (45.7 KB)
Kodi 19.5 windows.log (62.1 KB)

Please include full Kodi log from both versions, CE and Windows/Linux where it works. Snippets aren’t enough for debugging.

new logs in the first post

Please make a new log from CE & Windows with this debug logging activated:

I guess it’s a pvr.iptvsimple issue as by the URL .mpd it should define it’s dash:

Also enable CURL logging.

ok, logs are here
kodi 19.5 win debug.log (228.3 KB)
coreelec 19.5 debug.log (200.8 KB)

I see that you are using never version of pvr.iptvsimple addon on Windows. I will make you addon to test on CE.

… and Coreelec 20 Nexus has the same problem

Did you tried using inputstream.adaptive instead of inputstream.ffmpegdirect?


yes, tried it and it works, but catchup doesn’t work (pause and seeking don’t work)

You can also setting mimetype until final solution is made.


Can you try some online dash stream to replicate this issue?

kodiprop mimetype … it still doesn’t work
i found another mpd stream source and same problem . It works on Kodi win

This is new addon with same version as in Windows.

tried pvr and it still doesn’t work

Do you have inputstream.ffmpegdirect logging enabled? I don’t know if it uses curl.


log ffmpeg
coreelec debug ffmpeg curl.log (224.5 KB)

So it doss seems to be the built in ffmpeg handling. Maybe post the Windows log too?

ok, log:
kodi win debug ffmpeg curl.log (394.7 KB)

The Windows logs aren’t the same did you turn on all the same options?

yes, all the same, but I see there is no cURL, but it was turned on, now I looked at it
Here is the new log:
kodi win debug ffmpeg curl 18.02.22.log (357.0 KB)