Looking for users with no working WiFi or BT

As we said already it’s not supported by 4.9 kernel. It should work on next 5.4 kernel someday…

ok, thanks Portisch.
(I didn’t realise your last note was a reply to me)

Hi Portisch,

I actually got my wifi working on my X96 Max Plus T(AM7256) by inserting stock wifi drivers( nvram_ap6354.txt and fw_bcm4354a1_ag.bin) and instructing dhd_config to load the correct nvram files… Bluetooth is still unusable though(Can pair my android phone, but can’t play audio to CE; nor can it pair a bluetooth speaker)

Stock firmware uses Linux Kernel 4.9 too so I guess maybe something outside the kernel is responsible for unusable WiFi and bluetooth?

Dear BCM4354 users @ruz88 @AlexHalogen @redger : please try this devel image:
227.32 MB file on MEGA

It’s based on 19.2 Matrix and you need to be already on CE-19 Matrix before update!

Please make a dmesg | paste log.

EDIT:
Here a new link. It should include the firmware needed:

Hi Portisch:

The log goes:
http://ix.io/3uZ4

WiFi isn’t working on 2.4/5G(Open nvram file failed); BT works for some devices but not others(while they work with stock).

Thank you so much for your time and effort!

Can you create file /storage/.config/modprobe.d/options.conf with the content

options dhd firmware_path=/usr/lib/firmware/brcm/fw_bcm4354a1_ag.bin nvram_path=/usr/lib/firmware/brcm/nvram_ap6354.txt

and reboot.

Nope that didn’t work - fw_path is correctly set but nv_path is still /usr/lib/firmware/brcm/.
However I tried to set the options manually by insmod dhd.ko nvram_path=/usr/lib/firmware/brcm/nvram_ap6354.txt firmware_path=/usr/lib/firmware/brcm/fw_bcm4354a1.bin - and WiFi is up and running(2.4G only).

I also tried inserting 17236 1 nvram_ap6354.txt \ to the nv_by_chip section in /usr/lib/firmware/brcm/config.txt, and WiFi is running(2.4G only). Replacing nvram_ap6354.txt with the file from stock firmware enables 5GHz.

Hope that information helps!

Ok, can you remove the file /storage/.config/modprobe.d/options.conf and use /storage/.config/modprobe.d/dhd.conf ?

Please drop this config.txt in /storage/.config/firmware/brcm/ and reboot and make a dmesg log again, thx

config.txt (507 Bytes)

Also remove /storage/.config/modprobe.d file from previous posts.

You can share your nvram config file?

Please try first the included nvram_ap6354.txt in the devel image. If only 2.4 does work try again with your nvram config file if 5GHz come available, thx

This is the newest i found right now:

5GHz problem can’t be reproduced - maybe I made a typo when insmoding late at midnight…
Anyway dropping config.txt in /storage/.config/firmware/brcm/ makes the wifi work with your nvram file

dmesg log:
dmesg_after_dropping_config.txt (97.0 KB)

Bluetooth is still not fully working though

1 Like

Hallo!
Habe mir auch eine X96 Box bei A… gekauft mit 4/32GB 1000Lan.
Klappt soweit sehr gut, aber leider kein BT und kein Wlan.
Installiert habe ich 19.2-RC3. Wusste nicht, dass es die Boxen mit verschiedenen Chips gibt. Mist.
Vielleicht einen Tipp, wie ich BT und Wlan ins laufen bekomme?
Vielen Dank & schöne Grüße aus Koblenz
Dirk

Hello!
I also bought an X96 box from A … with 4 / 32GB 1000Lan.
Works so far very well, but unfortunately no BT and no WiFi.
I installed 19.2-RC3. Didn’t know that there are boxes with different chips. Damn.
Maybe a tip on how I can get BT and Wlan running?
Many thanks & best regards from Koblenz
Dirk

udevadm info /sys/bus/sdio/devices/*
P: /devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
L: 0
E: DEVPATH=/devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:1
E: SDIO_CLASS=00
E: SDIO_ID=037A:7603
E: MODALIAS=sdio:c00v037Ad7603
E: SUBSYSTEM=sdio

P: /devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:2
L: 0
E: DEVPATH=/devices/platform/ffe03000.sdio/mmc_host/sdio/sdio:0001/sdio:0001:2
E: SDIO_CLASS=00
E: SDIO_ID=037A:7663
E: MODALIAS=sdio:c00v037Ad7663
E: SUBSYSTEM=sdio

Die Masse der User versteht kein deutsch, nur Englisch.
Pls write in english, You can use google translator

@sunny-ko @jdy @username1 about the 037a:7603 Wifi modul:

We are not able to find the correct driver for our 4.9 kernel version. All we find do require a kernel 5.2 or newer. So maybe one of you can make a dmesg log of Android as we guess the Wifi is working there. Maybe this shows more information what driver is used. Also any of you can contact the vendor of the device and request the driver source.

Thank you for the support.

Hello, I have the same problems, I can make wifi and bluetooth work adding the

fw_bcm4354a1_ag.bin
nvram_ap6354.txt
config.txt

to /storage/.config/firmware/brcm/

However I could not make bluetooth work in proper way. I have the contact of the vendor, maybe it could give me the driver source, which files I need to request ?

The Linux driver. Complete and compatible with Linux 4.9.

Thank you, will ask and let you know

Hello,
I contacted the vendor, unfortunately he couldn’t provide me with the files, he said that he are just working for android drivers, not for linux.
I’ve reproduce the issue that I’m having and this is the log: http://ix.io/3wST

To describe the issue: I want to connect two ps3 controllers for gaming, ps3 controllers need to connected via mini usb cable and then disconnect in order to be recognized via bluetooth, so I do that and works fine for the first controller, but second controller doesn’t work following the same steps, also, when I reboot the system, the first controller is not automatically detected when I press the scanning button on it, so it seems that the bluetooth drivers are not to stable in Matrix_rc3, at least with the x96_Max_Plus2_T device.

Read on internet I’ve found this github repo; GitHub - winterheart/broadcom-bt-firmware: Repository for various Broadcom Bluetooth firmware</tit

On that the owner said that " Some Bluetooth controller (for example, BCM4354 and BCM4356) are integrated to WiFi chipset. These devices requires two kinds of firmware - first for WiFi, and second for Bluetooth. Without WiFi firmware Bluetooth will not initialize and will not work properly. Firmware for WiFi already included to kernel, but you may need to do additional work to place correct NVRAM."

Thanks a lot, will keep collaborating

They are the same.

hi and hi all,
how can you make the WiFi work with these? And where are these files available?

I have a working x96max plus and I bought another this spring, I wanted to install it for my mum, but WiFi doesn’t work. Bluetooth wouldn’t be necessary. I’d like her to be able to stream youtube videos over Yatse to the device.

As I see, the issue isn’t sorted out yet…
Is there a way to have just working WiFi?

Thank you very much in advance.
PS. I haven’t been able to test LAN, but that wouldn’t be an option anyway.