Looking for users with no working WiFi or BT

It looks like your WiFi chip will not supported ever. The chip manufacturer will not release any sources in public, so no support for chip with ID: 02E7:9082

There is only this source available without a known status:

So it might work, but maybe not. You will be able to perform some tests to get this WiFi chip running?

EDIT: it does not even compile, so without any source from the manufacturer there is no way to add a driver for this chip.

This firmware does also not exist on old platform. Please make a dmesg | paste with 9.2.8. but I guess there is a older driver used so it is compatible with your hardware.

Bluetooth started working out of nowhere on 4.9 kernel, CE 19.4 build, but just shows the name of one device, the others just the address and the connected status.

Now on 9.2.8 legacy:

dmesg: http://ix.io/3UY6

Sorry I took a long time, I was having a problem with the SD Card, I think.

That is the diff:

Host SW:, FW:, HW:QCA9377_REV1_1


Host SW:, FW:, HW:QCA9377_REV1_1

No idea why, need to check the QCA firmware

1 Like

@DiogoSilva please download this tar:

Extract it local and copy everything to your µSD in folder on your 19.4 µSD:

Or when you access the CoreELEC device by share it should be in folder COREELEC/Configfiles/firmware/qca9377

So you will have a file as example:

When you copied all reboot and make a dmesg | paste again.

1 Like

Were you ever able to this this working? I am trying to get a S905X box with the same WiFi working, but I am having the same issue you described.

@wizardknight instead asking a user with not responding you might try the infos I prepared?

I just tested CoreELEC-Amlogic-ng.arm-20.0-Nexus_nightly_20220507-Generic.img on a A95X-B7N (s905x) box. The onboard wifi did not see any connections at all, and does not appear to be working. I believe this unit uses the QCA9377 wifi chipset.
I am using gxl_p212_1g.


Why reproduce the work, if I can just ask for the outcome? Do you redo the work of everyone else rather than building upon the work already done?

Because the user never said if it worked or not?

The path COREELEC/Configfiles/firmware/qca9377 does not seem to exist.

Can you confirm that is correct?

/storage/.config/firmware/qca9377 does not seem to exist either.


I tried creating the directory you refer to, and extracting the file contents to it. There was no change in the wifi’s behavior.

dmesg | paste


ls /storage/.config/firmware
ls /storage/.config/firmware/qca9377

ls /storage/.config/firmware

ls /storage/.config/firmware/qca9377
LICENSE.qca qca9377-firmware-aml-1.0.0-3.tar
bdwlan30.bin qwlan30.bin
otp30.bin utf30.bin
qca utfbd30.bin
qca9377-firmware-aml-1.0.0-3 wlan

hmm, it looks like it still load old firmware:
Host SW:, FW:, HW:QCA9377_REV1_1
No idea yet

The directory you told me to put it in didn’t exist. Could you have the path wrong?