Looking for users with no working WiFi or BT

Were you ever able to this this working? I am trying to get a S905X box with the same WiFi working, but I am having the same issue you described.

@wizardknight instead asking a user with not responding you might try the infos I prepared?

I just tested CoreELEC-Amlogic-ng.arm-20.0-Nexus_nightly_20220507-Generic.img on a A95X-B7N (s905x) box. The onboard wifi did not see any connections at all, and does not appear to be working. I believe this unit uses the QCA9377 wifi chipset.
I am using gxl_p212_1g.


Why reproduce the work, if I can just ask for the outcome? Do you redo the work of everyone else rather than building upon the work already done?

Because the user never said if it worked or not?

The path COREELEC/Configfiles/firmware/qca9377 does not seem to exist.

Can you confirm that is correct?

/storage/.config/firmware/qca9377 does not seem to exist either.


I tried creating the directory you refer to, and extracting the file contents to it. There was no change in the wifi’s behavior.

dmesg | paste


ls /storage/.config/firmware
ls /storage/.config/firmware/qca9377

ls /storage/.config/firmware

ls /storage/.config/firmware/qca9377
LICENSE.qca qca9377-firmware-aml-1.0.0-3.tar
bdwlan30.bin qwlan30.bin
otp30.bin utf30.bin
qca utfbd30.bin
qca9377-firmware-aml-1.0.0-3 wlan

hmm, it looks like it still load old firmware:
Host SW:, FW:, HW:QCA9377_REV1_1
No idea yet

The directory you told me to put it in didn’t exist. Could you have the path wrong?

Any new ideas?

When I get more free time I will prepare a test image with the old firmware

@wizardknight please update with this image:

Just place the tar in the update folder and reboot.
After the update please run dmesg | paste.

No change in behavior.

It looks now a “newer” firmware:

Host SW:, FW:, HW:QCA9377_REV1_1

I don’t have such hardware and have no idea what else could be the reason. I recommend a hardware upgrade or any official supported hardware.

Internal Wi-FI doesn’t work on stable Matrix 19.5-rc1 and latest nightly build 19.5-Matrix_nightly_20220521
Device: X96Max Plus5 2G/16Gb
WiFi Chip: Amlogic W150S1
Bluetooth: not installed