Looking for users with no working WiFi or BT

Tried dietpi (just to see if it works there) and it loads rtl8xxxu.ko for RTL8723BU WiFi and works ok.

In the latest stable coreelec 19.5-Matrix_rc2 (Amlogic-ng.arm) that modules is disabled, do I really need that module for RTL8723BU wifi to work or is there another module that makes it work also?

CoreELEC:/etc # cat /etc/issue
#                  CoreELEC                  #
#            https://coreelec.org            #

CoreELEC (official): 19.5-Matrix_rc2 (Amlogic-ng.arm)

CoreELEC:/etc # zcat /proc/config.gz | grep RTL8XXXU
# CONFIG_RTL8XXXU is not set

Can you try this image with CONFIG_RTL8XXXU=m?

1 Like

Just figured out how to make a build myself but it’s still building… your image works like a charm, both wifi and bbluetooth… thanks!!!

Now gotta figure out how to get this in the official releases :slight_smile:

[    3.516915@5]- usb 1-1.2: Vendor: Realtek
[    3.516921@5]- usb 1-1.2: Product: 802.11n WLAN Adapter
[    3.516923@5]- usb 1-1.2: rtl8723bu_parse_efuse: dumping efuse (0x200 bytes):
[    3.516925@5]- usb 1-1.2: 00: 29 81 03 7c 01 08 21 00
[    3.517004@5]- usb 1-1.2: RTL8723BU rev E (SMIC) 1T1R, TX queues 3, WiFi=1, BT=1, GPS=0, HI PA=0
[    3.517006@5]- usb 1-1.2: RTL8723BU MAC: 00:13:ef:f1:b9:bc
[    3.517008@5]- usb 1-1.2: rtl8xxxu: Loading firmware rtlwifi/rtl8723bu_nic.bin
[    3.517679@2]- usb 1-1.2: Firmware revision 35.0 (signature 0x5301)
[    3.629404@4]- lcd vlock_en=1, vlock_mode=0x4
[    3.805409@0]- meson6-dwmac ff3f0000.ethernet eth0: fail to init PTP.
[    3.806075@0]- IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    3.938836@0]- proc: unrecognized mount option "hidepid=invisible" or missing value
[    4.318716@0]- usbcore: registered new interface driver rtl8xxxu
[    4.319057@4]- usbcore: registered new interface driver btusb
[    4.322531@2]- Bluetooth: hci0: rtl: examining hci_ver=06 hci_rev=000b lmp_ver=06 lmp_subver=8723
[    4.322537@2]- Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_config.bin
[    4.323045@0]- Bluetooth: hci0: rtl: loading rtl_bt/rtl8723b_fw.bin
[    4.326609@2]- Bluetooth: hci0: rom_version status=0 version=1
[    4.326639@2]- Bluetooth: cfg_sz 68, total size 24088
[    4.349651@2]- IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  827.774686@1]- wlan0: authenticate with ac:9e:17:95:dd:39
[  827.781351@1]- wlan0: send auth to ac:9e:17:95:dd:39 (try 1/3)
[  827.782977@1]- wlan0: authenticated
[  827.789623@1]- wlan0: associate with ac:9e:17:95:dd:39 (try 1/3)
[  827.814849@1]- wlan0: RX AssocResp from ac:9e:17:95:dd:39 (capab=0x1411 status=0 aid=1)
[  827.815956@1]- usb 1-1.2: rtl8xxxu_bss_info_changed: HT supported
[  827.816868@1]- wlan0: associated
[  830.094976@0]- IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

I will push the change to github.


Thanks for all your help and have a nice day!

Hi, I bought this box.
Probably a new revision with this wifi module: Fn-Link K255B-SR
I used sc2_s905x4_4g.dtb and wifi is not working.

udevadm info /sys/bus/sdio/devices/*: http://ix.io/46xS
journalctl -l: http://ix.io/46xT

Can anyone help? Thanks

Please open your device and check the assembled wifi chip. If it’s something like W150S1 I can try to prepare a test image but I would not give to much hope this will work. Never ever buy X… devices!

disassembled image: imgBB
It is: Fn-Link K255B-SR
Datasheet: https://fccid.io/2AATL-K255B-SR/User-Manual/User-Manual-5353179.pdf

Thanks for you time

@9martin you use ce-19 or CE-20?

I tried:

  • CoreELEC 19.5-Matrix_rc2
  • CoreELEC-Amlogic-ng.arm-19.5-Matrix_nightly_20220804
  • CoreELEC-Amlogic-ng.arm-20.0-Nexus_nightly_20220726

Same everywhere, Wi-Fi doesn’t work (log from CE-20: dmesg and udevadm info /sys/bus/sdio/devices/*).

@9martin here is a CE-19 test image including the Amlogic W1 driver:

I have no idea if this will work as no user did report back anymore about this wifi chips. Please update with this image and run a dmesg | paste afterwards and check if wifi get working or not, thx.

No change, WiFi/BT still not working.

There happen a kernel oops, so I guess no chance to get the driver working without a dev in touch with the hardware. That’s why CE do not recommend to buy such cheap hardware. You don’t know what you get and maybe it will not work fully ever…

Just got my Tanix X4 today and it all works fine in Android 11. Configured an ultrafast 32GB SD card with CoreELEC 19.5 rc2 and all booted fine into CoreELEC but only using the standard generic SC2 dtb. If I try the 1G LAN dtb it does not boot. I tried both as there is ambiguity as to whether this new Tanix X4 box has a Gigabit LAN port or a standard 100Mb one as you see some listings saying its 1Gb (1000Mb) and some saying 100Mb. Anyway it must be only 100Mb as the 1Gb DTB will not work at all.

So for feed back to others here asking I can confirm that I have NO Bluetooth device available, NO WiFi available and NO VFD files I can find that work for the front panel display (was kind of hoping the Tanix TX5 Deluxe S905X3 working VFD.conf file would work wihtthe X4 but alas it does not). I have not tested the SPF port as have not the means to do so.

I appreciate this is a new model box and we only just have the first compatible CoreELEC firmnware for it, so I will have to be patient. I do not have the up to date expertise to be able to make a VFD file but I see others here are already working on it so appreciate what they are doing. Anyway I can live without Bluetooth and always use an Ethernet LAN connection with my main streaming box via my TV cabinet’s Gigabit LAN Switch. So I am patient to wait for the WiFi and Bluetooth drivers to become available here.

Many thanks to all the CoreELEC developers for the new rc2 update which makes the X4 boxes now available for all us grateful CoreELEC users.

For the Vacuum Fluorescent Display you can follow the directions listed here. You may want to skip right away to the troubleshooting option.

For Bluetooth, WiFi and LAN, please follow these instructions to assist our developers with obtaining required information.



And a bit of a refresher:

A post was merged into an existing topic: Nightly builds (NEW)

Okay no WiFi or BT on my Tanix X4 device here is the link from the above SSH command:- http://ix.io/48uz I hope that is correct and that a suitable device tree can be coded to enable the WiFi and BT to work on my new box

This use the Amlogic -S1 chip, no working driver do exist in public

So the Tanix X4 box is a waste of money then. Will there be a driver for it eventually do you think?

Ask your vendor, not us. We don’t have any such source or hardware.