Looking for users with no working WiFi or BT

Bought a cheap vontar x2 with S905W2 (2gb dtb).
Ethernet is OK but wifi/bt doesn’t work.

There’s nothing to read on devices dir:
CoreELEC:/sys/bus/sdio # udevadm info /sys/bus/sdio/devices/* | paste
Unknown device “/sys/bus/sdio/devices/*”: No such device

And here’s the dmesg:

This is on nightly NE (same result on stable).

Thanks for your help

Your Kodi does crash, upload all logs.

Hola, tanix tx3 mini s905w2 4Gb/64 no funciona bluetooth con Nexus 20

This is the result of lsusb on my X96 MAX+ ULTRA S905X4 with the dongle Bluetooth ASUS USB-BT400, that is not recognized by NE , but is recognized by NG :
And the result of dmesg
Some idea where i can find the driver for NE, obviously included in NG ?
Thank you very much for your help.

I just think it must be enabled in Linux config but need to have a look in more detail

As per this post CoreELEC 20.1-Nexus Amlogic-ne Discussion - #10 by gujal
Here is the requested information
It is internal BT, so udevadm output

dmesg output

Thanks for looking into this

BT is not supported on Amlogic w1-aml chip. There does no driver exist yet.

1 Like

Strange that the kernel blob that Amlogic provide does not support their own w1-aml chip.
Thanks for your prompt response.

Driver is not in Android SDK Kernel???

Bluetooth in Android Version works on your Box?

Driver is only available for Android, not Linux.

1 Like

On my HK1 Rbox X4S wifi is not working on CoreELEC 20.1 NE. It is working on 20.1 NG. However Bluetooth works. Its not a big deal because I use wired internet on the box, but it would be nice to get it working.



Please update with this test build and check if Wifi is working:

by SSH:

cd .update
megadl https://mega.nz/file/TDJ3zZab#u8fbTkdcl8a08JcFLSR4SWkLdi-U1AICdJbk00YnDYE

Or manually drop the TAR file in the update folder.
Please make a dmesg | paste again after the update.

TX3 mini+ , s905w2 2gb internal wifi is not recognized.

Both Wifi and Bluetooth are working now. Thanks a lot for the quick update.


S905X3, 4/64/100M
Android works fine, both ethernet and wifi

Installed 20.0 Nexus with sm1_s905x3_4g
No wifi and in Coreelec settings there is no on/off switch for wireless
Tried with sm1_s905x3_4g_1gbit, does not start at all.

Installed 19.5, no wifi either

Wanted to try with sm1_s905x3_4g_1gbit_slowsdio dtb but that doesnt exist in the dtb library anymore…

Before I start doing random tests with older Coreelec versions and different dtb’s, Doe anyone have better tips to get wifi working on Coreelec?


dmesg: http://ix.io/4sIP

TOX3 (Amlogic S905X4), no WiFi, did not check BlueTooth. This is a new installation on a 128GB microSD card.


TOX3 (mobo S905X4_TOX_V3.0) “second version started from December 2022”
wifi chip - rtl8822cs

20.1_ne WiFi OK BT OK
21.0_ng WiFi OK BT OK

21.0_ne WiFi No BT OK
In the list of networks, all networks are visible, but when try to connect, nothing happens.

Fresh install - sc2_s905x4_4g_1gbit.dtb
from CoreELEC-Amlogic-ne.aarch64-21.0-Omega_nightly_20230402-Generic.img.gz

Most recent update seems to have really messed something up for my Wifi. I can’t seem to get my machine to connect to anything besides my Yatse controller of all things. If I’m able to figure out a way to pull the logs I will.


You all can try to enable the slow sdio mode like we had with old kernel. It looks like the device is found but it can not write to it. So try these cmds:

fdtput -t i /flash/dtb.img /soc/sdio@fe088000 max-frequency 170000000

Also please make a complete CE log from NG where the Wifi is working.

Do this through SSH?
Then I got it

CoreELEC (official): 21.0-Omega_nightly_20230402 (Amlogic-ne.aarch64)
Machine model: Amlogic
CoreELEC dt-id: sc2_s905x4_4g_1gbit

CoreELEC:~ # mf
CoreELEC:~ # fdtput -t i dtb.img /soc/sdio@fe088000 max-frequency 170000000
Couldn’t open blob from ‘dtb.img’: No such file or directory

And how make a complete CE log?