Looking for users with no working WiFi or BT


I’m still ask my vendor to share with me the drivers of the X96_max_plus2_T, but they are hard to get.

I’ve done a dmesg on the stock system of the box and this is the log: https://file.io/ziFgaBpc1p47
Also, I’ve adb pull the files in /vendor/etc/bluetooth: Filebin | 9cldsh0qn6pkrnfv
And files in /vendor/etc/wifi/buildin: Filebin | 4iih49iozpmf5v6r

Hope it would help, many thanks

The file you requested has been deleted

Sorry: Filebin | urtv5hndd8iwlcrf

Hi, fortunately, my vendor have provide me with the drivers :smiley: : Filebin | 3wmvawur87i68dza

Hi, the drivers folder have been deleted, here are the files again: drivers

Does anyone have some contribution?

This are firmware files not a driver.

Ohh :frowning: which format must have the driver file ?

@kevinrivm please try your firmware with CoreELEC 19.2_rc3 if it get better.

Download the files here and place them under the folder:
Create the folder if it does not exist by like:
mkdir -p /storage/.config/firmware/brcm

Then reboot and post a new dmesg log.

Hi @Portisch and @vpeter thanks.
I’ve done what you ask, however it seems not improve the behaviour of my PS3 controllers, still can’t pair 2 at once.

Here is the dmesg after reboot: dmesg.txt

BTW, my vendor have provided me with other files, in the driver format you ask: bcmdhd 100 10 315 x tar

And it really works on Android? Now the same firmware was used. But I think maybe it’s not possible to pair both controller at once. CE only handle by audio devices. Same for auto connect. It’s designed for audio speakers, not controller.

You can test with EmuELEC if both get paired or not and if the reconnect is working. If yes it’s CE system. If not it’s bt hardware fault.

I do use 2 bt PS3 controller with EmuELEC without issues. Never tried it on CE as there is no need for a media system to handle multiple controller.

I used 19.2-Matrix_rc3 (Stable) from a USB flash gxl_p281_2g on a x96 mini + 2/16Gb box. CoreELEC starts up. Wifi and display do not work. I know that gxl_p281_2g is designed for x96 mini which has another wifi adapter.
x96 mini only 2.4GHz
x96 mini + 2.4/5 GHz
Is it impossible to do with it?

I’m sorry for my english.


Look at first post and make a log.

I post the issue here because is a CE forum, the fix is really for EmuELEC, but since it’s based on CE, I think was the same. I’ve the same problem in EmuELEC, I cannot pair 2 controllers at once in this version of x96 max plus in contrast to the other ones which use the cdtech 4761743, so I can conclude it’s an issue with the drivers.

Can you teach me some way to add the drivers directly to the source code? then I’ll make the complete image to see if that work

SDIO_ID=8888:8888 does mean nothing.

Maybe make a dmesg log from Android and/or open the device and get the hardware assembled in your device.

Hi, I bump this thread because I have an x96 max+ 2/16 with a new wifi 2.4+5Ghz that is not working on CE 19RC3. I tried nightlies (matrix and nexus) but same problem. My other x96 max+ 2/16 is wifi 2.4GHz only and works great.

Here’s my dmesg including dhd if that can help.
Don’t know how to check which wifi chip I have into this box.
Thanks for your help!

CoreELEC:~ # dmesg | grep dhd
[    0.710224@2] aml_wifi wifi: [wifi_dev_probe] dhd_static_buf setup
[    0.710247@2] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem(): 100.10.545.3
[    0.710762@2] Wifi: bcmdhd_init_wlan_mem: bcmdhd_init_wlan_mem prealloc ok

The problem is the device X…
X… == low quality == you never know what you get

udevadm info /sys/bus/sdio/devices/* | paste

This is from CoreELEC

I was happy to get a 5Ghz wifi working on android
Thanks for your help

I recommend to buy a better device, buy cheap, buy twice.

Here’s a dmesg from android.
x96 max plus 2/16 + wifi 2.4/5GHz

Hope you can find something interesting on here.

No, I do not find any information about the driver in internet. You maybe contact your device vendor and ask for the driver source.

Again an advice to users: DO NOT BUY any X… device!