Looking for users with no working WiFi or BT

hmm, it looks like it still load old firmware:
Host SW:, FW:, HW:QCA9377_REV1_1
No idea yet

The directory you told me to put it in didn’t exist. Could you have the path wrong?

Any new ideas?

When I get more free time I will prepare a test image with the old firmware

@wizardknight please update with this image:

Just place the tar in the update folder and reboot.
After the update please run dmesg | paste.

No change in behavior.

It looks now a “newer” firmware:

Host SW:, FW:, HW:QCA9377_REV1_1

I don’t have such hardware and have no idea what else could be the reason. I recommend a hardware upgrade or any official supported hardware.

Internal Wi-FI doesn’t work on stable Matrix 19.5-rc1 and latest nightly build 19.5-Matrix_nightly_20220521
Device: X96Max Plus5 2G/16Gb
WiFi Chip: Amlogic W150S1
Bluetooth: not installed


Wonderful, the first user with W1 chip. I mad a test image long ago and didn’t got a response yet. Sure it will not work in nightly as the driver is not included.

Please test and make a dmesg log with this image:

Here is dmesg log: http://ix.io/3Ymr

And WLAN works now or not?

Wireless Networks available now at Network settings, but there is no WLAN interface at Connections


Please provide the result of:

udevadm info /sys/bus/sdio/devices/* | paste

Here is result: http://ix.io/3Ynb

You need to get a demsg log from Android. No idea how but Google is your friend.
Or you open your device and attach a UART converter.

Here is Android dmesg: https://pastebin.com/raw/8qEfuZ7p

Is there a guide or any documentation on how to add /compile firmware for Coreelec?
I can give it a go, but I have no idea where to start besides creating the compelling environment.


Thanks for developing Coreelec.:slight_smile:

X96Max does not work with Edifier 1280DB Bluetooth Speakers. I got this sound.


On Android works fine. Also with Beelink MXIII CE 9.2.8

I had to create a second account, been waiting for the other one to be unlocked for ages, I was trying to answer at the time, and wasn’t working and was blocked. Don’t know what happened and still can’t reply or send messages there. But I would be happy to still help fix the issue. I remember I did what you asked, and it showed the firmware version installed but the issue persisted.

I installed CE 19.4 on my X96 Max 2G (100Mbits) with the g12a_s905x2_2g.dtb but Wifi is not working.
Retried with the legacy 9.2.8, same result.

dmesg log: dmesg log[ 0.000000@0]d Booting Linux on physical CPU 0x0[ 0.000000@0 - Pastebin.com

device scan: http://ix.io/3ZZj

Previously wifi worked, just since the reinstall it does not work again.