Losing signal to my TV


First of all let me start by saying that English is not my native language so go easy on me.

Ok, now for my problem.

I have an LG Oled C8.

This tv as an option called HDMI ULTRA HD DEEP color.

If i have this option ON, i see the coreelec logo and thats it, my tv go to the screensaver, meaning i can see nothing on coreeelec.

If i have this option OFF, i can get into coreelec, but as soon i try to play, any movie, tv show, i get the screensaver from my tv again.

I have changed HDMI cables, i have changed HDMI ports (all of them suport HDMI ULTRA HD DEEP color) and nothing works.

My box is an old minix u1.

I would apreciate any help.

Thank you.

First of all make sure to set the resolution in CE settings to 1080p 60Hz.
Then turn on UHD Color. (reboot)
See if you get a picture, if you do, try playing the “problematic” videos and see if it works.
If it goes to the “screensaver”, then while in this state, SSH to CE and run the command dispinfo and post the URL it returns for us to review.
But really, this sort of issue is usually due to bad HDMI cables. It’s recommended to test with a short (up to 2m/6ft) cable, that has HDMI High-Speed certification.

I encountered something similar in the past.
First step (replace with good quality HDMI cables) fixed it. I recommend starting there for sure.

First of all let me start by saying thank you for replying.

It seems i had to have the limit display color depth to 8bit turned on.

What i don’t get is, my TV (LG OLED C8) is supposed to be a 10bit panel, so why should i limit the color depth to 8bit?

Im not discarding the HDMI cable just yet, But i bought and HDMI cable just yesterday (21/04/2021), it is a Ugreen 4K HDMI 2.0, I think that should be enough, ohh and it just 1M/3Ft.

Why am i saying I’m not disregarding the HDMI cable? Because sometimes i turn off the 8bit limit display color depth, and everything works, but most of the time i have to turn on 8bit limit display color depth, to get image.

Other times i play a movie (4k for example) and it play just fine and smooth, the “Minute” i hit stop, it should go back to the kodi menu, but nop i get the screensaver from my tv saying “No signal detected”.

On another note, as you know English is not my native language, so obviously i need subtitles. But now everytime i try to download a Subtitle from (legendasdivx.com) i get this error;

mercedes benz c class 0 60

Any tips on what should i do?

Many thanks.

Is it TV Box <—> TV or do you also have an AVR/Soundbar/something else connected between them?
We have multiple users with LG OLED TVs, I have a B7, and it works just fine with any resolution and color depth.

Install “RAR archive support” addon from repository…

It is TVBOX<---->TV only.

You have a B7 and you don´t need to to have the limit display color depth to 8bit turned on?

Ok that is strange.

With my TV (OLED C8), i only seem to have picture if i have the limit display color depth to 8bit turned on.

Could it be the HDMI cable or the box itself (since it´s an old minix u1)?

Thank you.

i Swear to God, that i installed that yesterday.

But as you suggested i uninstalled and installed again.

And it works, well kinda. After the download is done, the movie/tv-show, freezes for about 10 seconds, that never happened before.

Is this normal behaviour now?

Thank you.

It’s likely to be an HDMI cable. We are pretty sure that OLEDs work well.
You can try the 4:2:2 toggle without the 8-bit one, maybe that will help. It should limit the b/w required a bit.

I also have a LG OLED C8 but connected to a Odroid N2, 10 bit works fine for me on this TV, your problem is either with your HDMI cable, HDMI port on your TV (have you tried another ?) or your minix u1

That’s actually how i worked around it before replacing the hdmi cable

Can you please tell in which port do you have your box connected?

Mine is in hdmi 2.

Yeah I’m starting to believe that too, that is the minix u1 and not the hdmi cables.

By the way, does hdmi 2.0 cable support 10bits, or only 2.1 cables?

Thank you.

Ok, but which box do you use? because I’m starting to believe the problem is with my old minix u1.


If i may make a suggestion? Odroid N2 , works mighty fine… I got it working with a Lg c8 and Denon x3500h.

Oh and before odroid , same as you minix U1.
When i got the U1 in 2015 it was advertise 10 bit… i watched a lot of anime and 10 bit was always problematic, made me believe it was to much to handle for the box.
But must say, for normal 1080p it was one of the best box out there…

Different boxes, minix u1 was one of 'em, some Chinese unknown boxes, and now Odroid N2, C4. All worked if I set 4:2:2 or changed cables to quality ones. But your experience may differ, of course.

1 Like

Do you have the option “Pause when searching for subtitles” enabled?

I made a video of what happens when i try to download a subtitle.

Note, before i changed to coreelec i used Libreelec, and this never happened.

Here the link to the video;

One more thing i noticed, when the movie starts you can see on the bottom right, saying processing, that never happened before either.

Thank you.

I tried to change to 4:2:2, without the 8-bit one, and it worked, BUT ONLY, while playing a movie.

As soon i hit stop the movie, instead of going to the kodi menu, he went to my TV screensaver…AGAIN.

I’m really starting to believe that the minix u1 cannot handle 10bits.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.