M8S+ Pro L - new model of remote controll


#1

Hello People,

I have some older Versions of this s912 Player (Mecool M8S+ Pro L 3/32).
I use the q201…3…dtb.img. All other images lead to a error on the USB-Controller, so I cant control the player at least with my mini-keyboard.

Unfortunally I cant even detect the key-codes manually, since I have following error message:

CorePlayer:~ # ir-keytable -t
No devices found

Any clue whats wrong?
Is a brand new player with fresh installation of latest coreelec Image

Thanks, regards,
Michael


#2

That’s usually a DTB problem, nothing to do with the remote.


#3

:slight_smile: Found that hint on other threats and tested some of them and edited to first text above. It still isnt working.
It is not the usual remote, it is a voice controlled too. But anyway you are right, the receiver seems not to work.

https://de.gearbest.com/tv-box/pp_1592326.html?wid=1640583&currency=EUR&vip=16786118


#4

ir-keytable via ssh

leads to:

Found /sys/class/rc/rc0/ (/dev/input/event2) with:
Driver: meson-ir, table: rc-empty
lirc device: /dev/lirc0a
Supported protocols: lirc rc-5 jvc sony nec sanyo mce_kbd rc-6
Enabled protocols: lirc rc-5 jvc sony nec sanyo mce_kbd rc-6
Name: meson-ir
bus: 25, vendor/product: 0000:0000, version: 0x0000
Repeat delay = 500 ms, repeat period = 125 ms

The original remote.conf, grabbed from android on this player has following lines:


#5

I have the Mecool M8S Pro L 3GB/32GB. I was mistakenly under the impression that the LAN on this box was 1GB. So I used the gxm_q200_2g (I think) the same one I used on my H96 Pro

I only tried Coreelec on this for a short while but it seemed to work ok. I used the Mecool KIII Pro remote, profile on my Logitech 350.

I mainly want to use Android, & the supplied remote didn’t have a mouse, which makes using some apps difficult. So I bought this

https://www.aliexpress.com/item/2017-Backlit-MX3-Air-mouse-with-Mic-voice-microphone-fly-air-mouse-IR-learning-remote-controller/32826150428.html

Which has wireless remote, so it should work on Coreelec


#6

yes. something similar I have too, but I want to be able to use the original remote.
With q200 files, USB is not working (and remote either)
With _2 files only 2gb of rams are used, isnt`t it?!

WIth my previus M8S pro L (same player), the remote worked perfectly after downloading the remote.conf from android and safe it on the correct destination inside coreelec


#7

Coreelec builds do not use remote.conf files


#8

A new Installation did it. Dont know why. Will check what caused it.


#9

I have the same box with the same remote. For me only IR (from the remote) works with this box (under Kodi). Very annoying. Right now i am using a Xiaomi Bluetooth remote, but every time i reboot the box, i need to manually “Trust and Connect” the remote again.

I would only need a simple remote, like the Xiaomi remote but without the struggle connecting the remote to Kodi.