Magicsee N5 Max S905X3 No WiFi No Bluetooth

Hello, I just bought this device and when I install CE on it, it doesn’t have wifi or bluetooth. I have magicsee n5 max s905x3 4/32 with 100 Mb LAN.
I install CE Stable with the sm1_s905x3_4g dtb file. I also already tried installing the CE Stable with the sm1_s905x3_4g dtb file and CE Nightly 9.2 with the sm1_s905x3_4g dtb file but both of them also didn’t have wifi or bluetooth.

I try to search for this problem before and try to ssh into my device, here is the results maybe it’ll help.


CoreELEC (official): (Amlogic-ng.arm)
CoreELEC:~ # ifconfig
eth0 Link encap:Ethernet HWaddr ****
inet addr: Bcast: Mask:
RX packets:149 errors:0 dropped:0 overruns:0 frame:0
TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:31701 (30.9 KiB) TX bytes:31668 (30.9 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

CoreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio*
Unknown device “/sys/bus/sdio/devices/sdio*”: No such device
CoreELEC:~ # dmesg | paste
CoreELEC:~ # iwconfig
-sh: iwconfig: not found
CoreELEC:~ # iw dev wlan0 scan
command failed: No such device (-19)
CoreELEC:~ # cat /proc/device-tree/le-dt-id
cat: can’t open ‘/proc/device-tree/le-dt-id’: No such file or directory
CoreELEC:~ # lsmod
Module Size Used by
8021q 36864 0
ir_rc6_decoder 16384 0
ir_nec_decoder 16384 0
ir_lirc_codec 16384 0
lirc_dev 24576 1 ir_lirc_codec
meson_ir 16384 0
rc_core 36864 6 ir_rc6_decoder,ir_nec_decoder,ir_lirc_codec,meson_ir,lirc_dev
mali_kbase 499712 3
joydev 24576 0
wireguard 139264 0
ip6_udp_tunnel 16384 1 wireguard
udp_tunnel 16384 1 wireguard
wifi_dummy 16384 0
amvdec_vp9 126976 0
amvdec_vc1 65536 0
amvdec_real 45056 0
amvdec_ports 200704 0
v4l2_common 16384 1 amvdec_ports
videobuf2_dma_contig 20480 1 amvdec_ports
videobuf2_memops 16384 1 videobuf2_dma_contig
v4l2_mem2mem 28672 1 amvdec_ports
videobuf2_v4l2 28672 2 amvdec_ports,v4l2_mem2mem
videobuf2_core 49152 3 amvdec_ports,v4l2_mem2mem,videobuf2_v4l2
amvdec_mpeg4 65536 0
amvdec_mpeg12 106496 0
amvdec_mmpeg4 40960 0
amvdec_mmpeg12 45056 0
amvdec_mmjpeg 32768 0
amvdec_mjpeg 40960 0
amvdec_mh264 163840 0
amvdec_h265 155648 0
amvdec_h264mvc 61440 0
amvdec_h264 147456 0
amvdec_mavs 49152 0
amvdec_avs 69632 0
amvdec_avs2 212992 0
stream_input 204800 12 amvdec_h265,amvdec_mavs,amvdec_mh264,amvdec_h264mvc,amvdec_ports,amvdec_real,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_mmpeg12
decoder_common 184320 18 amvdec_h265,amvdec_mavs,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,amvdec_ports,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mmpeg12,amvdec_mpeg4
firmware 28672 18 amvdec_h265,amvdec_mavs,amvdec_mjpeg,amvdec_mh264,amvdec_mmpeg4,amvdec_h264mvc,amvdec_mmjpeg,decoder_common,amvdec_real,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs,amvdec_vc1,amvdec_mmpeg12,amvdec_mpeg4
media_clock 45056 12 amvdec_h265,amvdec_mavs,amvdec_mh264,decoder_common,amvdec_ports,firmware,stream_input,amvdec_vp9,amvdec_h264,amvdec_avs2,amvdec_mpeg12,amvdec_avs
amlvideodri 24576 0
videobuf_res 16384 1 amlvideodri
videobuf_core 32768 2 amlvideodri,videobuf_res
videodev 286720 6 amlvideodri,v4l2_common,amvdec_ports,videobuf2_core,v4l2_mem2mem,videobuf2_v4l2
media 40960 1 videodev
fbcon 61440 0
bitblit 16384 1 fbcon
softcursor 16384 1 bitblit
font 20480 1 fbcon
CoreELEC:~ #`

When you first powered it up to Android, did it go through a firmware update process before you installed CE?

If you run udevadm info /sys/bus/sdio/devices/sdio* what is the result?

Also look at this thread where it was found that the WiFi/BT module was damaged and I have also read elsewhere that there may also be a loose wire in the box.

No, I didn’t have any firmware update before installing CE.

CoreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio*
Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

I don’t think my WiFi/BT module is damaged as it is working in Android but when I boot into CE neither WiFi nor BT is detected.

I have Magicsee N5 Plus which is same hardware as Max and wifi and bt working perfect on 9.2.3
I’ve checked now my MAX and also working.

There was a thread not too long ago where WiFi and BT were not working in CE and there seemed no explanation as to why.

In the end, the user reflashed Android and CE was then able to detect the module.

Firmware available here.

You can also see if there is an update available from within Android settings.

I tried installing CE 9.2.3 but unfortunately it still didn’t detect WiFi or BT.

Is there any other alternative solution I should try before reflashing the android firmware?
There are no update available in the Android settings.

Thanks for the help.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.