Magicsee N5 Plus 4/64 Recovery Mode

Hello. My box updated to KODI 19 and I tried manually get back to KODI 9.2.7 by Update in KODI. After that my box booting in stock firmware. When I’m trying to install new CoreElec from USB it goes to Recovery Mode.
I tried a few versions like 9.2.5, 9.2.6, 9.2.7 etc. and a few dtb. I’m creating a fake and after select it in UPDATE tool it goes to Recovery Mode.
I am asking for help in solving the problem.

Which DTB I have to use? My TV BOX is a Magicsee N5 Plus 4G. I was tried sm1_905x3_4g, sm1_905x3_4g_1gbit, sm1_905x3_2g, sm1_905x3_2g_1gbit and it wasn’t worked.

cat /proc/device-tree/amlogic-dt-id shows that my dtb is sm1_ac213_4g but I don’t see that dtb anywhere.

DTB’s I was tried to use gave me that errors:

First of all, do you still have android on your device? If nothing is working in booting to CoreELEC you might have a problem with your bootloader so i would restore a version of android that you’re sure that works with CoreELEC. Then I would just use an uSD card or USB and do the usual stuff. Boot the device with the reset button pressed or use boot to libreelec from google play. From what I’ve understood you already had the device running CoreELEC so it’s not a dtb problem

1 Like

I have Android which booting automatic since I was tried to downgrade Kodi 19 to 9.2.7 by manual update in CoreElec (previously CoreElec was primary OS). Since that time booting stock Magicsee N5 Plus firmware and when I’m trying to install fresh CoreElec I have errors like in screenshot in upper post. I was tried to install new CoreElec by fake - then I have errors like on screenshot in upper post like Footer is wrong, Signature failed etc. When I boot the device with the reset button it’s goes to Recovery Mode too and show “dead” robot with “No command” line.

Did you have to restore android or was that the android you originally used to boot CoreELEC the first time, when it worked?

1 Like

That was android I originally used to boot CoreELEC the first time. When CoreElec “crashed?” after “bad” update, next startup was original BOX Android.

As I’ve read, you want Leia, so download 9.2.7 amlogic-ng. Make sure it’s -ng. Burn the usb pen with rufus or etcher and copy the correct dtb (the one you used the first time, when it worked). Try all the usb ports. In your case i would also try uSD and another usb drive because it can be a problem with a corrupted device. And report back.

1 Like

Change the pendrive helped. I am very grateful for your advice! I wouldn’t think a working flash drive might not work with TV BOX. Best wishes for you! :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.