Mapping keys for Mele F10 air mouse

I am trying to configure an old model of Mele F10 air mouse. On one side it has a keyboard, and on the other side it has a circle pad with arrows and some buttons which are mostly used with an air mouse. Now, for navigation in kodi I prefer to use only keys without an air mouse (since with an air mouse the pointer jumps all around the screen and interferes with keys’ usage), but I want to use keys on the side with the circle pad (since arrows on the circle pad are much more convenient to use than arrows on the keyboard side). When I disable mouse in Kodi, the arrows on the circle pad, ‘Enter’ button and some other buttons work as expected, but ‘back’ button doesn’t do anything. I want to fix that.

In order to do that, I used evtest to find out this button’s scancode, created a hwdb config file, put it into /storage/.config/hwdb.d/99-mele.hwdb, ran ‘udevadm hwdb --update’, and reconnected the device, but this didn’t help.

This is what I have in the hwdb config file:


Seems that I got things right: indeed, lsusb says:

Bus 001 Device 008: ID 1915:af11 Nordic Semiconductor ASA

so it seems that a match string is correct. I also tried to map some other keys on the circle pad side to a backspace, but still no success - keys that didn’t work before remapping continue not to work, and keys that were doing something before remapping (for example, circle pad side has a ‘Home’ button which works as expected when a mouse is disabled) continue to do it even after I remap them to other keys.

Do you have some idea how to fix this problem?

Hi, have a look at this: Mele F10 Fly Mouse met XBMC/Kodi (OpenELEC/LibreELEC)
It works on CE too, I have the same remote. Good luck.

Thanks. My mistake was due to a usage of lower case letters in a match string - it is necessary to use upper case letters there for both ‘Vendor’ and ‘Product’ parts.

I have a similar problem but different remote. How did you find the name for the hwdb file?