Mecool KI Pro not booting from SD with correct dtb.img, fake?!

I just bought a Mecool KI Pro and it doesn’t boot with the dtb.img from your device tree. I extracted the dtb.img from Android. Could someone tell me if this is really a KI Pro?

The extracted dtb.img shows:
�Amlogic����������amlogic, Gxbb������������gxl_q20x_1g�������

dtb.img is here:

I tried several dtbs but it doesn’t boot. However, it boots from the openvision 7.0 image for the KI Pro.

I don’t know anymore what I could try…ideas are more than welcome.

You need to activate aml autoscript with tootpick

I did. It doesn’t boot from the SD card with dtb.img files I tried.

Open your box send photo.

@taki let me know if you need to see a certain chip better.

High resolution.

Wifi chip is different than k1 pro. K1 pro used ap6255. Your board like k3 dvb ddr4.
Openvision img uses https://github.com/OpenVisionE2/meta-linkdroid/tree/develop/recipes-bsp/linux/linux-amlogic-3.14.29/k1pro/gxl_p230_k1_pro.dts
There no different but openvision uses kernel itb format not img format.
1 write sd card coreelec img.
2 open fat parttions and goto device tree folder copy to root gxl_p230_k1_pro.dtb
3-gxl_p230_k1_pro.dtb rename to dtb.img
4 insert card to k1 pro
5-push to tooth pick
6 plug device
7 wait 8-second
8-no push tooth pick

This is what I did. It doesn’t work. With the same method, openvision boots. Honestly, I don’t know where the problem could be. Is there a way to figure it out without UART debugging? I don’t have a UART board around.

Is there a log which I can get from the SD to see why it doesn’t boot?

I tested:

gxl_p230_k1_pro.dtb -> not working
gxl_p230_2g.dtb -> not working

By the way. I do have another KI Pro for a long time. The same SD boots for that one.

coreelec autoscript
defenv
setenv bootfromnand 0
setenv upgrade_step 2
setenv sddtb ‘if fatload mmc 0 ${dtb_mem_addr} dtb.img; then else store dtb read $dtb_mem_addr; fi’
setenv usbdtb ‘if fatload usb 0 ${dtb_mem_addr} dtb.img; then else store dtb read $dtb_mem_addr; fi’
setenv bootfromsd ‘mmcinfo; if fatload mmc 0 ${loadaddr} kernel.img; then run sddtb; setenv bootargs ${bootargs} bootfromsd; bootm; fi’
setenv bootfromusb ‘usb start 0; if fatload usb 0 ${loadaddr} kernel.img; then run usbdtb; setenv bootargs ${bootargs} bootfromusb; bootm; fi’
setenv bootcmd ‘if test ${bootfromnand} = 1; then setenv bootfromnand 0; saveenv; else run bootfromsd; run bootfromusb; fi; run storeboot’
saveenv
run storeargs
run bootfromsd
run bootfromusb
Openvison
setenv linux_start_mmc “if fatload mmc 0 1080000 kernel.itb;then echo E2 mmc ;; bootm 1080000;fi;”
setenv user_start “if mmcinfo; then run linux_start_mmc;fi;”
setenv preboot “run factory_reset_poweroff_protect;run upgrade_check;run bootmode_check;run init_display;run storeargs;run upgrade_key;run user_start;run switch_bootmode;”
saveenv
run preboot
Uses difference script. Openvision can boot your device. You have to change uboot autoscript
your k1 search kernel.itb file on flash part. Thus dont boot with kernel.img

Do I understand you right that I should change the autoscript to what you wrote and copy the kernel.itb?

openvision k1 img is running on your device. You wrote wrong autoscript on uboot. therefore you need to write coreelec autoscript.
You have to make toothpick method.
Pull off the last reset button after viewing the boot screen

I tried openvision and it was working. I flashed Coreelec and copied the correct dtb and it is not working. Sorry, if I was not clear.

The SD card booting Coreelec on my old ki pro doesn’t boot on my new ki pro. This indicates the hardware is different. Right?

Only wifi different

Could this different wifi chip prevent booting to Coreelec?

What could cause it?

Need to look uarth log what preventig at boot

try change “SD” card
or try boot via android terminal : “reboot update”

I tried to change already. As well as booting from USB. Nothing worked. What does “reboot update” do?

download app terminal emulator for android
then write this command : reboot update

  • this command well go to Coreelec boot

“reboot update” boots Coreelec. Here is the dmesg. WIFI is not working.

dmesg: http://ix.io/1NWG

From the dmesg I can see that it has some troubles.

Rebooting via the GUI reboots but it freezes at the mecool logo. Removing power shortly reboots the box to Coreelec again.

Any ideas are welcome. I can provide any information required. Except for UART, I would need to order a reader first but maybe we can figure out what the problem is.

Update: Upon reboot the box freezes at the mecool logo. Removing power boots to Coreelec. Sometimes it freezes, sometimes it boots directly into Coreelec. Any idea is welcome.

From what @taki said, the WIFI chip is different like the one of the K3. How to adapt the dtb file? Unfortunately, I don’t understand enough of this topic to solve it by myself.

Your dtb gxl_p231_2g_dvb