Mecool KM9 PRO - amremote config file not updating DTB

hi Coreelec dev team.
I have spent 4 hours this morning reading all the threads I can find on this box and getting the bluethooth remote working fully and Im at a dead end have conceded to ask for some help. There are no error logs to upload as technically no error is recorded by the unit.
I have paired the bluetooth remote in coreelec settings, ver is latest 19.2 RC3, the remote works …almost. BUT the OK/ enter button does not work. ( this problem is widely reported, but not on how to fix it) Everything else does work, even the power off and power on, without having to use the BL301 Hack. So I researched the remote repo and found the remote.conf file for my exact remote supplied with my KM9 PRO its this one https://github.com/CoreELEC/remotes/blob/main/AmRemote/MeCOOL%20M8S%20Pro/MeCOOL%20M8S%20Pro.png - i also tried to use the one under the Mecool KM9 pro and still did not work.
I copied it to both to root and the .config folder in coreelec, however the automatic update of the DTB and reboot does NOT happen. nothing… So I’m stuck. either the instructions
given at How to configure IR remote control are incorrect or I’m just missing something…
fyi I have also tried to use the keymap editor under global / navigation / enter, then a 8 digit code is recorded by the keymap editor (the XML is generated, I’ve checked), but when you save it and back out, nothing, does not work. Also kodi v19.1 under android 9 on my box works 100% with the remote and no need to use the keymap editor at al, so its not ‘kodi’ related otherwise the enter / OK button would not function. Its something only seen in Kodi/coreelec
thanks for your help in advance.
mark

About | FAQ | Terms of Service | Privacy Policy | Legal Notice