Mecool KS2 DVB T / T2 Amlogic S905 Soundbar TV Box-- Tuner not found

#1

Hi all,
I have Tv box with this spec: Brand: MECOOL
Core: Quad Core
CPU: ARM Cortex-A53
GPU: Mali-450
Model: KS2
RAM: 1G RAM
RAM Type: DDR3
ROM: 8G ROM
System: Android 5.1.1
Type: TV Box
Processor: Amlogic S905
1000M Gigabit Ethernet, WiFi 2.4G, and Bluetooth 2.1

I am using CoreELEC-Amlogic.arm-9.0.1-Generic.img + gxbb_p200_1G_1Gbit (gxbb_p200_1G_1Gbit_RealtekWiFi) + TVheadend server. TVH can not detect tuner. Are there any chance to make it working???
LOG+Dmesg http://www.uschovna.cz/en/zasilka/MQNC2Y5ZET8CL742-874/
THX.

1 Like
#2

This box is unsupported by CE.
With gxbb_p200_1G_1Gbit_RealtekWiFi.dtb any chances to work. No HW details about dvb tuner. You can try dtb with dvb tuner e.g. gxbb_p200_ki_plus.dtb but this has only 100M ethernet.

#3

Hi thx for answer.Tuner is with SONY D2837ER - https://mysku.ru/blog/china-stores/62210.html

#4

It looks like Wetek Play2 DVB-T modul. Try to test gxbb_p200_2G_wetek_play_2.dtb and after reboot submit via ssh ‘dmesg | paste’ for kernel log.

#5

HI ,
it is not boot with gxbb_p200_2Gwetek_play_2.dtb

with gxbb_p200_kI_PLUS.DTB

13.785250@1] dvb_meson dvb.49: Found i2c-1 adapter: aml_i2c_adap1
[ 13.785264@1] dvb_meson dvb.49: ts0: parallel
[ 13.785341@1] dvb_meson dvb.49: ts0_control: 0x0
[ 13.785392@1] dvb_meson dvb.49: dev_name=dvb
15.002982@1] dvb_meson dvb.49: DVB demod detection for i2c-1 (aml_i2c_adap1)…
16.222986@1] dvb_meson dvb.49: Checking for Availink AVL6862 DVB-S2/T2/C demod …
[ 16.223063@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223068@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223120@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223125@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223175@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223180@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223186@1] i2c i2c-1: dvb_meson: i2c wr failed=-11 len=3
[ 16.223238@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223242@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223292@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223297@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223345@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223351@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223356@1] i2c i2c-1: dvb_meson: i2c rd failed=-11 len=4
[ 16.223405@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223410@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223459@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223464@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223512@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223517@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223521@1] i2c i2c-1: dvb_meson: i2c wr failed=-11 len=3
[ 16.223571@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223575@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223624@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223629@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223678@1] i2c i2c-1: [aml_i2c_xfer] error ret = -5 (-EIO)
[ 16.223683@1] i2c i2c-1: token 1, master_no(1) 300K addr 0x14
[ 16.223687@1] i2c i2c-1: dvb_meson: i2c rd failed=-11 len=4
[ 16.223692@1] i2c i2c-1: dvb_meson: attach failed reading id
[ 16.223697@1] dvb_meson dvb.49: Failed to find AVL6862 demod!
[ 16.223702@1] dvb_meson dvb.49: Total DVB modules found: -1
[ 16.226643@1] dvbdev: DVB: registering new adapter (dvb_meson)
[ 16.228336@1] DMX: dmx0 irq:55
[ 16.235466@1] DMX: ts0 irq:51
[ 16.235532@1] DMX: ts1 irq:-1
[ 16.235572@1] Meson DVB frontend(s) registered successfully.

1 Like
#6

Try this dtb gxbb_p200_1G_1Gbit_ks2.dtb (40.0 KB)

1 Like
#7

Ks2:~ # dmesg | paste
http://ix.io/1Il6

12.385142@2] wetek-dvb dvb.50: Found Wetek i2c-1 adapter …
[ 12.385156@2] wetek-dvb dvb.50: ts0: parallel
[ 12.385236@2] wetek-dvb dvb.50: dmx rst ctl = ffffffc033be6a80
[ 12.385245@2] wetek-dvb dvb.50: asyncfifo rst ctl = ffffffc033be6940
[ 12.385253@2] wetek-dvb dvb.50: ahbarb0 rst ctl = ffffffc033be6b40
[ 12.385261@2] wetek-dvb dvb.50: uparsertop rst ctl = ffffffc033be6c00
[ 13.199957@2] wetek-dvb dvb.50: Checking for Sony CXD2841ER DVB-C/T/T2 demod …
[ 13.199967@2] i2c i2c-1: cxd2841er_attach(): I2C adapter ffffffc0268038e0 SLVX addr 6e SLVT addr 6c
[ 13.200262@2] i2c i2c-1: cxd2841er_attach(): attaching CXD2837ER DVB-T/T2/C/ISDB-T frontend
[ 13.200267@2] i2c i2c-1: cxd2841er_attach(): chip ID 0xb1 OK.
[ 13.200735@2] i2c i2c-1: MxL603 unable to identify device(00)
[ 13.201014@2] wetek-dvb dvb.50: Failed to find MxL603 tuner!
[ 13.241417@2] i2c i2c-1: Sony ASCOT3 attached on addr=60 at I2C adapter ffffffc0268038e0
[ 13.241431@2] wetek-dvb dvb.50: Total Wetek NIM(s) found: 1
[ 13.246993@2] DVB: registering new adapter (wetek-dvb)
[ 13.247003@2] DVB: wetek_dvb_init: Registered adpter: wetek-dvb
[ 13.252198@3] DMX: async fifo 0 buf size 385024, flush size 12032
[ 13.252249@3] DMX: async fifo 1 buf size 385024, flush size 12032
[ 13.253453@3] wetek-dvb dvb.50: DVB: registering adapter 0 frontend 0 (Sony CXD2837ER DVB-T/T2/C demodulator)…
[ 13.253619@3] DVB: wetek_dvb_init: WeTeK dvb frontend registered successfully.

1 Like
#8

Hi,
you are a magician:-) It works!! Many Thanks!!