MECOOL M8S PLUS (new, s905x2)

I have a box like this mecool m8s plus, new version with s905x2.
I tried to run CE versions that support s905x2 (19.5, 20, 20.1) and failed.
Boot from usb with led, it looks like the kernel is loading and rebooting (boot loop).
On the monitor: logo screen, black screen, etc.
I used dtb like this: g12a_s905x2_2g.dtb, g12a_s905x2_beelink_gt1_mini.dtb

I also have the original android 9 dtb file:
mcg12a-u212-2g.dtb (76.8 KB)

== EDIT ==
I added support for this box, maybe it will be useful to someone. Unfortunately, I was unable to support DVB-T.

diff --git a/arch/arm64/boot/dts/amlogic/Makefile b/arch/arm64/boot/dts/amlogic/Makefile
index 9a58fe36b8b4..8b4d0333fdb2 100644
--- a/arch/arm64/boot/dts/amlogic/Makefile
+++ b/arch/arm64/boot/dts/amlogic/Makefile
@@ -6,6 +6,7 @@ dtb-$(CONFIG_ARM64) += g12a_s905x2_beelink_gt_mini_a_2g.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905x2_beelink_gt_mini_a_4g.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905x2_beelink_gt1_mini_2g.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905x2_beelink_gt1_mini_4g.dtb
+dtb-$(CONFIG_ARM64) += g12a_s905x2_mecool_m8sp.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905y2_2g.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905y2_4g.dtb
 dtb-$(CONFIG_ARM64) += g12a_s905y2_radxa_zero.dtb
diff --git a/arch/arm64/boot/dts/amlogic/g12a_s905x2_mecool_m8sp.dts b/arch/arm64/boot/dts/amlogic/g12a_s905x2_mecool_m8sp.dts
new file mode 100644
index 000000000000..789a416b6d80
--- /dev/null
+++ b/arch/arm64/boot/dts/amlogic/g12a_s905x2_mecool_m8sp.dts
@@ -0,0 +1,27 @@
+#include "g12a_s905x2_u211.dts"
+#include "coreelec_g12_common.dtsi"
+	model = "Amlogic";
+	coreelec-dt-id = "g12a_s905x2_mecool_m8sp";
+	/delete-node/ bt-dev;
+	gpioleds {
+                status = "okay";
+		sys_led {
+                        gpios=<&gpio_ao GPIOAO_11 GPIO_ACTIVE_HIGH>;
+                };
+	};
+&sd_emmc_a {
+	status = "okay";
+	sdio {
+	    f_max = <40000000>;
+	};
+&i2c3	{
+	status = "okay";

Me cool isn’t supported and maybe not booting at all.

Thanks for the answer, that’s what I expected. :frowning:
What do you have to do to make unsupported into supported?
Is modifying the dtb (dts) file enough?
I saw here that versions with other (old) processors (s905w) worked with CE.

I did a little research and this tv box works and boots up to version 19.5-Matrix_rc2. Version 19.5-Matrix_rc3 is already in a bootloop.
I checked what has changed between these versions and it’s about this commit:
DT: switch g12a to multi-di · CoreELEC/linux-amlogic@669cf60 · GitHub

I currently have 20.2-Nexus installed on the box and it works fine with the dtb.img file before this commit.

The wifi doesn’t work and I don’t know how to fix it. I have info from android 9 , dts and dmesg. Would this be enough to fix the wifi??

If you have dtb from android and it work with coreelec you solved problem or not ?
And if you know that this commit is problem just create your own dtb a use it.

How did you extract dtb file from running Android ? In my Android there is no dtc command line.
I backuped /proc/device-tree with tar.gz on usb and then try create dtb from fs in running coreelec but this dtb was not working with coreelec.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.