Media format problems

Hi folks,

I use onlinetvrecorder.com a lot recently, but many video files I get from there cause problems. For videos in AVI containers the navigation does not work, i.e. if I try to move forward, the time-marker jumps back to start, and audio and/or video are offset or gone. In most cases the video continues at the desired position, but audio is off, but it is not always the same. Playing the file in other players (Windows Media Player, VLC…) has no problems. Here’s what VLC’s codec information says about such files:

VideoCodec: H264 - MPEG-4 AVC (part 10) (H264) 720x576 @25 fps
AudioCodec: MP3, Stereo, 48 kHz, 32 bits per sample, Bitrate 192 kB/s

Also not working:

VideoCodec: H264 - MPEG-4 AVC (part 10) (H264) 1920x1080 @25 fps
AudioCodec: MP3, Stereo, 48 kHz, 32 bits per sample, Bitrate 192 kB/s

Interestingly, the same codecs in an MP4 container just work fine.

Any ideas?

Thanks!

Quick add: Just tried LibreELEC 9.2.1 on Raspi 4 - the same files work flawlessly there. Unfortunately the combination LibreELEC & RPi 4 still has lots of other issues…

I have, in the past, found odd behaviour from .AVI files, so whenever I come across one now, I run them through mkvtoolnix to create an MKV and I never seem to have issues.

I’m not saying that this is an answer but worth trying.

Thanks for the tipp, will give it a try. Still, would love if I did not need to add this step…

Edit: Works very well, and since it is just re-containerization delightfully fast. Thanks again for the Tipp!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice