Mini m8s ii S905x NAND deleted? Help needed please

Hello to all.

I need some help please.

I was experimenting between Libreelec and Coreelec images on sd for many years now and somehow i must have deleted the partitions of the NAND. So the device doesn’t boot from NAND. I get a bootloop like this: GXL:BL1:9ac50e:a1974b;FEAT:ADFC318C;POC:3;RCY:0;EMMC:0;READ:0;CHK:AA;SD:0;READ:0;0.0;CHK:0;

The bootloader and partitions may have been deleted somehow. Booting from SD still works.

I booted Libreelec and tried installtointernal but i got:

One of BOOT, SYTEM, DATA or DTB partitions is missing. Make sure that you are using a correct device tree and a device with internal memory!

I think i have tried all simple recovery options. I tried with burn card maker and other card makers. I also tried AML burn tool 3.1 with “update_MINIM8SII_rv112_megabox_20170320.img” and other roms and i get at 9% 0x30405004 UBOOT/Partition boot/Verify partition/Error result. I see only HUB5-3!
UART log with aml burning tool and ATV rom

Below you can check the ssh and serial logs:

ssh log

UART log

My experience with Linux and embedded devices is basic. Can you help me make the NAND functional again?


I believe installtointernal isn’t supported anymore in CE, maybe in LE. If you can successfully boot from SD card you should try this install on internal memory.
If not you need to unbrick the device with the shorting pins methode aka mask rom and flash an android image to have a new bootloader.

See also this:

Hi Garcea.
Thanks for your answer. Coreelec doesn’t boot from sd. Libreelec boots from sd. Also if i burn a firmware with BurnCardMaker, the sd boots but i get errors with eMMC partitions and fails: sd booting with Burncardmaker - android firmware

Have you tried to reflash with Amlogic Burning Tool? If you don’t have the original Android img you should try ATV Experience v.4 for 905X (has an Android Pie bootloader).

I have tried AML burn tool with “update_MINIM8SII_rv112_megabox_20170320.img” and i get at 9% 0x30405004 UBOOT/Partition boot/Verify partition/Error result. I have tried other roms as well with the same results.
Probably the partitions are messed up and can’t be written correctly.

I think it’s the end…

Did you also reset the nand chip by shorting the pins? SHORT PIN

@Portisch Ok i have bought an s905x3 so i will not cry about the old box.
But i can boot libreelec so the box is not totally garbage. And since I can run Linux and other things on sd, why can’t I format and repartition the eMMC? I just need someone experienced to guide me.

@Garcea i have tried also to short pin.

When Burncardmaker isn’t working it will no be working.

If you have UART connection you can enter the bootloader console and run defenv and the saveenv.
Then reboot and hold the reset button with the uSD and CE on it.

EMMC is probably past its max write cycle lifespan or has just decided to give up the ghost. Box is >5 years old so its not unheard of. Not a total loss though, if you can run stuff from SD.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.