MiniX Neo U22-XJ CE19.5 no LAN

Dear developers, users

i am using a MiniX Neo U22-XJ box and recently the LAN connection in the box is not working.
This means that the BOX does not receive Internet via LAN cable and the IP address is: 169.254.4.123 (or similar). LAN setup is IP Address auto. I would like to continue using the box with a LAN connection because it fits perfectly into my home network.
I upgraded the CoreELEC from version 19.5-Matrix_rc3 to 19.5-Matrix Final. This update was offered by the box. In version 19.5-Matrix_rc3 was LAN.
I tried to replace the .dtb file with the file in the CoreELEC nightly builds, but it doesn’t work either.
In Android mode LAN connections work and have internet.
(I made log files with WiFi connections)

If you know any solution to the problem, please write it to me.

Thanks.

Sorry for my English

CoreELEC 19.5-Matrix Final

http://ix.io/4krt
http://ix.io/4kru
http://ix.io/4krv

Hello satel

I can confirm your problem. I had the same issues with 19.5-Matrix final and 20-Nexus final.
In both installs, clean or upgrade the Minix Neo U22-XJ lost connection with the LAN interface.
I solved the issues in both cases by using the dtb file g12b_s922x_minix_u22xj.dtb from the last release canditate 19.5-Matrix_rc3 and 20-Nexus_rc2.
There is defintely an issue with the DTB file.
Both coreelec versions worked flawlessly after this change.

Yes, I can confirm. Same behavior. After update no boot if done from scratch (reset method) or no Lan if bootable. Only after using the propper rc3 dtb.img it works back again. If haven’t any issue reporting possibility in coreelec github. Is there a way to do so, or is this the report devs are looking at.

Thank you
#kodi-support #development:development-testing

Thank you very much for your help. The LAN internet is working :slight_smile: