Minix Neo U9-H doesn't adjust display framerate (solved) - Whitelist settings on display under system


I’m using CoreELEC 8.95.1 on a SD card on my Minix Minix Neo U9-H.
I am using the dtb gxm_q200_2g_minix_neo_u9 from inside the Corelec partition and Coreelec starts and works fine except for the adjust display framerate. It always plays the videos (1080p, 4K, 24 fps, 25 fps, 60 fps) with the display definition that is in settings of Kodi (1080p 60fps for example).
It happened with previous version of CoreELEC 8.95.0.
It seem that there is a problem with the device tree…
Do any one knows if there is an alternate device tree for Minix Neo U9-H ?



You have to select all required resolutions and refresh rates in Whitelist settings

R U sure all required resolutions in refresh rates?

I said in Whitelist and not in refresh rates. Please read attentively.

1 Like

Thank you very much for your help.
I can’t still understand how I missed that configuration. I’ve played with every configuration inside Kodi except that one.
Sorry for asking something that was already answered on this forum, and thanks again for you help.

I’m about to migrate to Coreelec from Libreelec.

How would this configuration look like in Kodi?


In Settings, display you have the Whitelist . Select the resolutions that work with your TV and thats it.
If you have a Minix U9 you will also need the Dirty Regions Fix that solve the subtitle rendering forcing frame skip problem.

1 Like

Cool, I do have a Minix U9, how would I apply that fix?
Also, is there a good guide how to migrate from Libreelec to Coreelec?

I didn’t found any guide but I did like this:

Did a backup in Libreelec under the libreeelec options in Kodi (selected an external HDD as the destination).
Created the Micro SD card with Coreelec and did a restore using the backup I made.

To fix the dirty regions I downloaded the file in this forum

Answer 273

And put it in /storage/.kodi/userdata/

1 Like

You can and should use the fix on Libreelec also. I noted that frame skipping when the subtitles appear (more often with x265 media).

I have that subtitle fix in my current Libreelec setup, but I think it was added in later builds?
Are you sure it’s not included in the current Coreelec version?

It wasn’t on the one I downloaded from here.

It’s not a fix nor a solution that I would advise as it increases temperatures considerably on the GUI.

Any other solution then? I’ve looked and only found that one…

No other fix, yet.
I use it all the time, but my temperatures never go over 55°C. (withot this fix temperature is usualy 50°C)
So, when you start to use this method, frequently check your proc temp.

AFAIK, Minix Neo U9-H is equipped with best passive cooling system on all these Amlogic boxes, so you should be in safe temp range…

Thank you. I will check the temp.

Great hint. I’ve had the same issue and solved it.

Libreelec (kazaq, Kypton) doesn’t take care about this configuration – framerate switching works anyway. Coreelec (Leia) uses the ‘whitelist’ and switches only to the selected resolution/framerates. Configuration is in ‘system settings -> videos -> 1st entry in the list’ (you need expert mode). Here you need to mark all allowed resolutions/framerates (colour changes from white to blue). Save it and framerate switching works.