Minix U22-XJ vs Odroid N2+, Minix wins?

hi all

please forgive any missing info am not 100% sure whats needed as i am experimenting ditching windows and for this being a wall of text

i purchased the minix box about 2 years ago and it wasn’t perfect for my needs and put in the tech draw, mother in law wanted to watch some bits i have so was going to give it to the mother in law as would do for her needs but after updating and puting vpeter’s java image on it then installed to internal, i found it was very nice for my needs and the speed was very good so set it up and tested for a week

So i then thought well lets get a N2+ as should be faster and i’ll keep it if i am deffinately ditching windows, it came with a 128gig emmc, so all set up installed to internal again and first i noticed it took a lot longer to boot than the minix did, carried on getting things going database linked and sources added etc, then on to my skin aeon mq9 and thats when it got real bad and basically lagged out, remote commands taking 30 seconds or more but cpu info etc carried on in real time on settings widget, could this be emmc lagging it down? as the default estuary skin appears fine and the minix handles aq9 with no problem, i guess i need to check in on a sd card install for make sure, just wondering if anyone has any experiance or ideas on the emmc? and why a skin causes it to fail

well sorry for the wall of text, i think it is the onboard ir not playing nice, covering with some electrical tape and using a usb reciver it is behaving a lot better, still quite slow to boot though :frowning:

A lot of text and problems. But not even the information about the used system and about the setup…

https://wiki.coreelec.org/coreelec:ce_support

was extremly sleepy when making this post, have played around and have experimented more still some issue’s but will repost with more info and things i have tried

Hi All

hopfully this will be a much better attempt at help.

Hardware N2+ going to Arcam avr to panasonic TV full hdmi 2.0 chain, 2160p and HDR, playback is perfectly fine and no issue’s but if i suspend the device when I wake it i have a black screen SSH still works and i can shut the box down with remote and switch it back on, have tried the 4:2:2 option also

dispinfo link http://ix.io/3UKs

and the disp_cap output
CoreELEC:~ # cat /sys/devices/virtual/amhdmitx/amhdmitx0/disp_cap
480i60hz
576i50hz
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz
720p50hz
1080i50hz
1080p30hz
1080p50hz
1080p25hz
1080p24hz
2160p30hz
2160p25hz
2160p24hz
smpte24hz
smpte25hz
smpte30hz
smpte50hz
smpte60hz
2160p50hz
2160p60hz*
640x480p60hz
1024x768p60hz
1366x768p60hz

my other issue is extremely slow boot when installed to internal 128gig card, from SD card it boots in less than 30 seconds, from eMMC it’s about 3 mins which is why i started to try to suspend the device not full shutdown

You get a black screen every time on resume from suspend? Or only sometimes?

I have something similar and it depends on the TV brand/type/firmware.

You can try to reset the display mode when you get black screen on resume by:

CoreELEC:~ # cat /sys/class/display/mode
1080p50hz
CoreELEC:~ # echo "null" > /sys/class/display/mode
CoreELEC:~ # echo "1080p50hz" > /sys/class/display/mode

You will find your setting by the cat command and replace 1080p50hz by your value. When send null to the display mode it should show no HDMI input on TV. If you get than a picture on the second echo command I guess this display reset after suspend happen maybe to early.

it is everytime so far, which is why the slow eMMC is a pain, i only need to fix either of those issue’s

CoreELEC (official): 19.4-Matrix (Amlogic-ng.arm)
CoreELEC:~ # cat /sys/class/display/mode
2160p60hz
CoreELEC:~ # echo “null” > /sys/class/display/mode
CoreELEC:~ # echo “2160p60hz” > /sys/class/display/mode
CoreELEC:~ #

and running this is black screen still at the end

Than it’s a different issue. AVR is between CE device and TV? Than you should try to connect the CE device directly to TV and use passthrough from CE device to TV and back to AVR by the ARC HDMI port.

i loose all forms of HD audio then which is a definate killer for device needs, and arc is just a pain once switched on, and this is the only device i’ve ever used to give HDMI problems

do you have any thoughts why the eMMC boot is so slow? as i’d like to suspend or a fast boot be available

little disapointed with the N2+ as mentioned in my first attempt at a help thread the Minix as awful as this sounds is better so far :frowning:

No logs, no idea
https://wiki.coreelec.org/coreelec:ce_support

hopfully these are the ones

latest kodi log http://ix.io/3ULh

latest crash log and configs http://ix.io/3ULk

configs and other debug info http://ix.io/3ULj

other info, avr is a Arcam AVR 550 and TV panasonic 65dx902b

orby, check with official CE 19.5 nightly image. Because seems the crash is related to java virtual machine for BD menus.

https://relkai.coreelec.org/

i have been testing with the official 19.4 image for slow boot and resume/suspend, the remote issue i am pretty sure is all down to the the MQ9 skin as i noticed it pegs one CPU core to 75 - 85%

Some progress on this

I was able to get a 64gb emmc and a usb emmc adapter and flashing direct to this and no slow boot anymore, will test the 128 this way soon also.