"Missing" Hard Drive after creating Symbolic Link

I am using the latest development build on an Odroid N2+ which has been a bit “sluggish” of late, which turned out to be that the eMMC was at 97% capacity, so I created a new directory on one of my external hard drives called “Thumbnails” and created a symbolic link with

ln -s ./storage/.kodi/userdata/Thumbnails/ ./var/media/sdd1-usb-WD_Elements_25A3/Thumbnails/
And then used MC to move the existing thumbnails to the external hard drive, rebooted, discovered it wasn’t working right, went in deleted the existing subdirectories under Thumbnails and the Textures13.db, rebooted again and let Kodi rebuild the thumbnails and artwork. Worked great, running full speed etc, thought I had it fixed.

The issue is that since then, the hard drive I set up the symbolic link to keeps going AWOL in Kodi, it’s there and mounted, will appear in file explorer, MC etc, Kodi “sees” the drive and all the media is accessible, it just won’t appear anywhere else.

Really stumped as to what the issue is, my assumption is that is the symbolic link being “soft” instead of “hard” but given the read only OS in CoreELEC I didn’t think that was possible to do, or it’s the due to something in the drive name (sdd1-usb-WD_Elements_25A3) but my Linux is very rusty, 5 years of contractually obliged Windows will do that to you.

Any suggestions?

I am suggesting to read this first.

So what exactly is the issue?

I did, and searched the forums.

It’s vanished under the “Videos” sub menu in Kodi, I’m trying to get it back. No idea why creating a symbolic link should throw this up.

Well its working again after the latest update, whatever you did to fix it, it worked though I would be curious to know what caused it to expand my linux knowledge.