Mount USB disk in write mode


#1

Hello,

I want to mount a USB disk in write mode.

I pluged the USB and it mount automatically in “/var/media/DiskName”, the problem is that I can not create files/directories:

mkdir /var/media/DiskName/recordings

mkdir: can’t create directory ‘/var/media/DiskName/recordings’: Read-only file system

Is it possible to use something like “/etc/fstab” to assign the mount path and options?

Kind regards.


#2

Whhat filesystem is using your USB disk? Make sure your drives are error free, and not in some hibernation or other sleep state from Windows.

If possible, SSH into your box, run the following commands and paste here the resulting URLs.

blkid | pastebinit
mount | pastebinit

#3

Hi,

This is a EXT4 disk.

blkid | pastebinit

http://ix.io/1xaf

mount | pastebinit

http://ix.io/1xag

Regards.


#4

Tried to replicate your issue with a couple of USB disk formated in ext4 as well. They mount correctly in rw mode, as expected.

Have you tried to eject (via kodi menu -> Remove safely), and plug it again? Does the issue happens even if you reboot with it plugged in? Maybe is useful to take a look at dmesg just after connecting the disk.


#5

Hello,

This is the dmesg when I plug the USB disk: https://paste.debian.net/1058173/

There a re some errors, but I don’t know how to fix them.

I will appreciate your help.

Kind regards.


#6

You need to do a file system check (fsck) on the partition/s of that drive.

It is a corrupted fs that is causing the drive to be re-mounted as read only - done to protect the integrity of the content of the drive.

[ 3872.024302@3] EXT4-fs (sda1): warning: mounting fs with errors, running e2fsck is recommended

[ 3878.407965@3] EXT4-fs error (device sda1): ext4_journal_check_start:56: Detected aborted journal
[ 3878.407996@3] EXT4-fs (sda1): Remounting filesystem read-only