Movie posters / art not showing up for new movies in GUI

I have a setup with 1 PC and 2 S905x (netbox a95x) units connected to a central sql mariadb database.

On the two S905x boxes, starting yesterday, all new movies I add show no artwork. When I look at the same movie in Kodi on the PC the artwork shows fine.
I am running the newest stable version of Coreelec ( and I have Kodi 18.8 on my PC.

I don’t think it is a database or scraper problem as the images show up fine on the PC.
I have also tried several skins, and there was no change.

Can anyone make a suggestion of something else I can check to figure out why the movie art is not showing up correctly on the Coreelec systems?

Here is what I am seeing on CoreElec:

Here is the PC:


I read the thread you linked to.
I saw two things that it said.

  1. DNS issue - try a public DNS
  2. TMDB addon needed to be updated.

I don’t think it is a network or DNS issue as my PC has no issues with the artwork. I also point to both and (public DNS servers) for my DNS requests.

That left the TMDB addon as the other possibility.

I manually forced the CoreElect system to update it’s add-ons. I have TMDB 5.2.1 installed. I do not have a way to verify this is the most current, but didn’t get an error when I made the update request.

I am still seeing the same issue.
Can you elaborate beyond pointing me to the thread, or make an alternative suggestion?


I just found this thread at the Kodi forums. Seems there is a larger issue.

Looks like CoreElec may need to update their TMDB addon code.

I saw this comment on another forum:
6 hours ago
Fixed by released 5 hours ago.

Any Mods able to forward this update request?

Yeah, it’s something wrong with the TMDB addon. It pulls no cover art for movies on my two CE boxes, nor does it work on a Rockchip box running LE.

The problem is also mentioned here: Bug cover - invisible

So now I use the TMDB Python add-on. That one works.

Download updated addon from developer

Confirmed working to Odroid and Khadas devices with Coreelek.

You might need to reimport your library tho’…or just remove remove movies w/out cover and scan library again, it is working just fine.

1 Like

I can confirm that after updating the MovieDB addon to 3.2.6 poster issue is solved.
Rerun update for newly added movies without posters from right click -> Information-> Refresh.
Tested on Odroid N2+ CoreELEC

It’s a Kodi issue. TMDB is maintained by Team Kodi.

Issue started for me yesterday as well, same as the weather service Gismeteo, seems to have broken at the same time. I guess I’ll switch services.

Team Kodi has released an update to the TMDB addon. The issue is resolved by updating to the latest version of TMDB. For support: see: Kodi Add-on Manager

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.