Missing Artwork for new movies

Hi guys, I have been running Coreelec with the N2 for close to a year now (Best decision I ever made) and for the most part it has been good. The only issue I seem to have is, every once in a while, artwork stop showing up for new movies. Before now when I get tired of the problem I just do a refresh and start all over again from scratch… However my library has become big and nuking to restart to fix an issue is no longer sustainable for me.

The issue started again about a week ago, newly added movies just have no artwork. I even installed Artwork beef but no show:

A brief system configuration:
Odroid N2, 4GB RAM, 32GB emmc (27.1G available). CoreELEC (official): 9.2.4.2

The system logs are available here http://ix.io/2w5e

Just to add that the same issue does not happen with TV series. Also, need to add that this issue just started. Never had any problem with artwork before now. I pretty much stick to official kodi repositories and the only addon I installed outside the repo is the artwork beef which was installed to try solve the issue not the problem persist non the less.

I there are some indicators and errors why this could be happening but they made no sense to me. All other move mẹta data shows just the movie artwork is blank.

I am left scratching my head wondering what I could be doing wrong.

This frequently happens when the IMDB tracker needs an update. IMDB is maintained by Team Kodi.

You could try to enable “fanart”, which might solve the issue temporary.

This problem has nothing to do with IMDB, the log shows the problem is with downloading the images from theMovieDB (image.tmdb.org) not IMDB

2020-09-03 11:16:53.567 T:3522732928   ERROR: CCurlFile::Open failed with code 0 for http://image.tmdb.org/t/p/original/nQJmWekGYlXhezGUb21xFfEfwhH.jpg:
2020-09-03 11:16:53.624 T:3472814976   ERROR: CCurlFile::FillBuffer - Failed: Server returned nothing (no headers, no data)(52)

The only problem I can see with the url’s is the extra colon : at the end, pasting the url into a web browser without the colon works fine and the image loads.

Your log also contains:

2020-09-03 17:18:06.913 T:3532645248 ERROR: CCurlFile::Stat - Failed: Couldn't resolve host name(6) for https://assets.fanart.tv/fanart/movies/64678/moviebackground/the-art-of-getting-by-54dc529176c98.jpg

and

2020-09-03 17:19:16.960 T:3464422272 ERROR: CCurlFile::Stat - Failed: Timeout was reached(28) for https://assets.fanart.tv/fanart/movies/19995/hdmovielogo/avatar-51290d0678d4e.png

And again both of these urls work fine in a browser, so at a guess it looks like a general problem with you having no internet connection / network connect at that time.

Yeah, seems like that, only I actually do have Internet connection, what is why I could download the other movie meta data like movie ratings, plot, cast and everything about the movie beside the album art. The url goes through from my browser. This is why I find the issue perplexing.

It seems to be a connection issue…except the n2 is actuallyconnected to the Internet.

Could this be a bug with Kodi or Coreelec. Or could this be a hardware issue. I never get this problem with TV series.

Have you tried refreshing one of the problem movies since your initial post 9 hours ago to see if it was a problem with the sites just being down, although the chances of both themoviedb and fanart…tv being down at the same time are slim but not impossible.

I’m adding new content every day using the Universal Movie Scraper and have never encountered missing art so I doubt it’s a Kodi issue.

I remember a while back that there was a problem following an update to The movie database where artwork/thumbnails were not being populated correctly and the advice at the time was to switch to another provider until it was fixed, so I switched to Universal movie scraper, which initially worked.

A few weeks ago though I started to see lots of missing artwork and thumbnails and could not see why. I had forgotten about the change that I had made a while back.

But then I remembered and went into each of my drives/network shares that contained media, went to edit source and switched back to The movie database and after a rescan of all the media, all of the artwork etc was successfully populated again.

I pretty much refresh items without artwork like 3 times a day. It was after I got tired, tried everything that I decided to come online to seek help.

Just added 6 new movies. All loaded without artwork. This is so frustrating not even knowing what the issue is and no one seem to have a clue. Do I just optimise my system for a rẹ flash and setup every time something like this come up… Is it an issue with emmc… Could I have installed an addon that messes up with things… I absolutely have no clue.

The inconsistency of the problem doesn’t help because TV Shows are not affected and other than the artwork,every other thing loads fine (meta data like plots, cast information etc) just the artwork is missing. And all this started about 2 weeks or so ago. I am not give in addons and have only the official repository enabled.

If this is a bug how do you reproduce or even report it?

Main error from the logs is here
2020-09-03 17:18:06.913 T:3532645248 ERROR: CCurlFile::Stat - Failed: Couldn’t resolve host name(6) for https://assets.fanart.tv/fanart/movies/64678/moviebackground/the-art-of-getting-by-54dc529176c98.jpg

and

2020-09-03 17:19:16.960 T:3464422272 ERROR: CCurlFile::Stat - Failed: Timeout was reached(28) for https://assets.fanart.tv/fanart/movies/19995/hdmovielogo/avatar-51290d0678d4e.png

Could it be a problem with curl? I would really appreciate pointers guy. This issue is so frustrating

Where can I find the log file for Kodi. I need to do some deep debugging. Tail -f the log file and see the issues that comes up.

I was able to ssh into the coreelec box and see the tail the error. basically
2020-09-05 05:17:21.637 T:3510289280 ERROR: CCurlFile::Open failed with code 0 for http://image.tmdb.org/t/p/original/bDgEwnPFcPrJcM5xvkt8EphZ9A3.jpg:

If I run a curl http://image.tmdb.org/t/p/original/bDgEwnPFcPrJcM5xvkt8EphZ9A3.jpg: --output somefile.jpg I am able to download the file fine which means me think something else it as work and curl works fine. I don’t know much about how kodi pulls artwork but whatever it uses seems to be based on curl and that system seems to be broken on my system.
One thing I want to try is increase the timeout for downloading artwork, but read I would need to do this from the advancedsettings.xml file. can anyone help point where the location of this file is? Or do I have to create it. If it is the latter, what basic format do I use that won’t resort to a broken system.
Please I need help… really trying to fix this.

Hi, did you try a NFO file with the right imdb page?
I,m always having trouble with asian movie titles, so i make sure i have the right one with an nfo file.

It turns out to be a network issue. For some reason Kodi artwork does not work with my main ISP which can be a bit slow but not slow enough that I can not watch 1080 from YouTube or download Torrent. I switched to a much faster LTE network from my mobile and the album art loaded up immediately.

Something is wrong with the way timeout and accepted latency is configured on kodi. Internet in my place is very spoty but I do get back especially at night. If I can find away to reduce the timeout or latency threshold that would fix the issue for me permanently.

Thanks to all who gave suggestions.

Again, it’s a Kodi issue, and it has been properly documented right here.

@Betatester Please indicate which section of that wiki page documents this as being a Kodi issue when the OP has just stated that it’s a problem with his network that he has fixed by using a different network.

1 Like

I won’t really say it is a network issue ie the network is not working fine. Like I said TV shows doesn’t have the issue and Movie other movie metadata loads fine… I only have issues with artwork. The network in question is my main ISP and while it is not the fastest, it should be able to download artwork just fine. I easily watch Youtube 1080p on this network without issues and I can download said album using curl on the same kodi machine.

My guess is something about the way artwork download works is optimized for super fast internet even though the job can be down with a 10mb or even 5mb per sec internet speed network. So this is still a kodi issue in my book. If I need super fast internet to download artwork, then something somewhere needs better optimization.
Note that TV shows on same kodi, same machine and same network works fine artwork and all.

Have you tried using a Public DNS Server on your N2? I recall a similar issue being resolved in this manner under Krypton.

Thanks actually makes some sense. I would look into it. The issue could definitely be DNS related due to the resolvable error that is common.

Any more revelations bigbrovar? I’ve been running into the same issues on my C2, but not my N2.

You gave yourself some possible pointers, so set-up a fresh install to an sd card and add the movies without any additional config and see what happens.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice