MxqPro Hevc/4k frame drops and lags

Movie taken with OP7 Pro. That’s 4k hevc, 30 fps. I am unable to play it on MxqPro, on phone it plays fine.

Link: https://mega.nz/#!aRNnGYqT!m_r8oJAa4RFGZyLKZ0PjGzY90x-fDHb2mcqEz1qtxDw

Big sound lag on MxQ/latest stable CoreElec and bunch of frame drops. Is even hevc/4k supported on S905? As I heard, it is, but apparently, it does not.

First the file you uploaded is actually 4k 60fps

However I’ve tried it on a really cheap generic S905X box and it plays perfectly fine. The only issue I can think of would be a network issue as the file is 43Mb/s.

Hmm not smootch on MxqPro

MxQ Pro do NOT support HEVCI change mine for this reason

It depends which MXQ PRO the OP has, I’ve managed to find multiple different ones. MXQ PRO seems to be a generic name that gets slapped onto any box.

S905X

S905

Even an RK3229

Regardless, all 3 chipsets support 4k h265

As I can see, hw decoder used, but playback hangs. The same goes to h264/4k/60fps

Well, tried on PC (Windows 10) with file I linked. Vlc only shows first frame, then sound goes and picture is hanged, there is no even cpu usage. Built in Windows 10 player asks me to pay (wtf).

All video players on Linux are similar to VLC on Windows.

What’s really wrong with that file?

[edit]
My box is on Android 7.1, so S905X I guess. Not Rockchip of course.

Copy your file to the box and play it locally to take network b/w out of the equation and try again.
If the above doesn’t It’s possible that the way the video is encoded just isn’t supported by the hardware decoder in the chip.

I played it locally from SD card device booted from. SD card is UHS-I, so should be pretty fast.

I’ve tried the file he uploaded on a cheap S905X box and is play’s perfectly fine, both over the network and direct from the box, I’ve also tried it on a Windows Pc and my Odroid N2 and again it’s fine. I don’t think there is anything wrong with the file (unless the OP uploaded the wrong file).

VLC on my Windows 10 PC plays it fine.

Cheap S905X box plays it fine as well.

As far as I can tell there is nothing wrong with the file you uploaded.

Well I’m out of luck then

It seems you were right. That’s not decoding problem, it’s rather sdcard too slow to handle such high bitrate. That really sucks. The same goes to usb disk (it’s usb 3.0, but it does not matter, as device only supports usb 2.0) and network. Card is UHS -I micro sd, possible adapter is so slow?

I am unable to watch 4k tv. Playback just hangs with black screen. 4k/hevc, sample:
https://mega.nz/#!LNtHHA7Q!EycVB5c3RRZqZ1gMlxFdvwREnGEJawf_mPkJmBeX1BY

Hevc should be supported, what’s the problem? It works just fine with Kodi on OP7 Pro

@adamg

I just figured it out. I own MXQ pro with S905W , not S905X - indeed, S905X has no any problems with HEVC. However, S905W has problems as I described and that’s definitely not issue with sdcard. Some hevc files plays with lags, some others don’t play at all.

Is there anything I can do with that?

S905W only supports 4k@30fps. So you need a new device to play 4k 60fps files.