Mygica T230 - Unsupported device

Hi I buy DVB-T2 usb stick GENIATECH MyGica USB TV tuner Stick T230C - https://www.aliexpress.com/item/1883597971.html

In Odroid N2 i see that device is unsupported

[ 1449.136879@3] usb 1-1.1: new high-speed USB device number 5 using xhci-hcd
[ 1449.261349@3] usb 1-1.1: New USB device found, idVendor=0572, idProduct=c68a
[ 1449.261352@3] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1449.261354@3] usb 1-1.1: Product: EyeTV Stick
[ 1449.261356@3] usb 1-1.1: Manufacturer: Geniatech
[ 1449.261358@3] usb 1-1.1: SerialNumber: 161xxx
[ 1449.262263@3] usb 1-1.1: Unsupported device

Tried to switch to another modules, but not found under ADDONS > Program ADDONS

Coreelec module drivers

Using latest coreelec 9.2.1, freshly installed.

In the main menu you have addons and there you’ll find CoreELEC Module Drivers. In addons you’ll find them in services. Try Crazycat or drivers from latest kernel. My t230 (not C) is supported in crazycat.

Also fresh install of 9.2.1. Also no CoreELEC Module Drivers. No crazycat.

lsusb says:

Bus 002 Device 003: ID 0572:c688 Conexant Systems (Rockwell), Inc. Geniatech T230 DVB-T2 TV Stick

Dmesg doesn’t print much when stick was plugged in. It says the below and that’s it.

[  930.652792@1] usb 2-1: new high-speed USB device number 3 using dwc_otg
[  930.652870@1] dwc_otg: Indeed it is in host mode hprt0 = 00001101
[  930.853323@3] usb 2-1: string descriptor 0 malformed (err = -61), defaulting to 0x0409
[  930.854336@3] usb 2-1: New USB device found, idVendor=0572, idProduct=c688
[  930.854345@3] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

Tried searching in addon browser…

Search for “coreelec” found only:

  • Script - CoreELEC Display Info

Search for “crazy” found nothing.

Addon browser only shows 2 repositories: CoreELEC Add-ons, and: Kodi Add-ons repository

Any idea where to start looking?

OK so I looked through the list of all installed add-ons and found CoreELEC Module drivers and DVB TBS as well as DVB drivers from latest kernel but these were DISABLED.

Enabled them all. Rebooted. Still unable to use the DVB stick in tvheadend.

I think my issue is different from OP’s. Sorry to thread-jack.

I can’t understand what you’re doing. You can’t enable them all. In the main menu you have the addons line. There you have the CoreELEC module drivers. You can choose one and it will ask for a reboot. If you try to enable all at the same time it won’t work.

2 Likes

Same problem in CoreElec V9.2.8:

[ 1516.302104@2] usb 1-2.1.3: New USB device found, idVendor=0572, idProduct=689a
[ 1516.302112@2] usb 1-2.1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1516.302114@2] usb 1-2.1.3: Product: USB Stick
[ 1516.302118@2] usb 1-2.1.3: Manufacturer: Gen
[ 1516.302120@2] usb 1-2.1.3: SerialNumber: 2017.12.09
[ 1516.302906@2] usb 1-2.1.3: Unsupported device

And the driver are installed:

2022-02-04 14:37:05.634 T:4065534016 NOTICE: ADDON: driver.dvb.crazycat v9.2.0 installed

Have you tried the other module, dvb drivers from latest kernel?

Yes, I tried all three possibilities, same problem.
In Matrix the device is detected instead, but unfortunately I should stay in Leia at the moment.

Here the solution in LibreElec, but i don’t know how to apply it because i can’t find references in the CoreElec code.

What’s your tuner? It can be the T230, T230C or T230A. This one is the substitute of the original T230 which was discontinued.
I had the T230 and it worked fantastically but the T230A is garbage, at least for DVB-C. I’ve tried with CE (supported in -ng), Libreelec (kernel 5.15 has support for the tuner) and in Ubuntu with kernel >5.15.

It’s the T230A: idVendor = 0572, idProduct = 689a.
And I guess it’s not covered in those drivers.

I don’t know what you mean, I have one, I told where it is supported. It’s a bad tuner, at least for now. Maybe there are some improvements that can be introduced in the future, maybe it works well for some in dvb-t. For now, and in the systems I tested it, it’s really bad, miles away from the T230, the best low cost USB tuner I’ve tried in DVB-C.

Do you have one with the same IDs?
idProduct = 689a?
And how is it possible that CoreElec 9.2.8 can’t find it and Matrix does?
I don’t see it in crazycat drivers, I mean as id.

1

Yes, that’s the one I have. Legacy doesn’t have the same crazycat version as -ng if I remember correctly.

1 Like

And where i can found 9.2.8 legacy image?
I use this one: CoreELEC-Amlogic-ng.arm-9.2.8-Generic.img.

Sorry, I misled you. I meant that as far as I remember, support was only introduced in CE19. So you won’t have it in 9.2.8 non -ng also. The one that can work is T230C but I never had one. I’ve been thinking of buying one for tests but I have other priorities in my shopping list. I just use USB tuners for testing, I use silicon dust hdhomerun devices for DVB-C (satip).