MySql on Wireless locks at boot until cable attached

So I have been an Kodi fan since early XBMC when I “altered” my first Xbox 18 years ago and have worked threw every platform and now found myself in love with the simplicity of CoreElec.

I have a NAS with content and Mysql that’s working perfectly via cat6 to multiple X96 Max boxes and nvidia’s
I want to put a TV outside and need to go wireless, after failure in the backyard I have moved the box inside where I can test and try to configure it…

First off I was on 19.2 and have how tried 19.4 rc2 with same symptoms… Basically it wont boot.
I works perfectly if the network cable is attached, I can then detach the cable, go into the CE settings and choose a my wifi network, the interface show me a star next to it and Connected and it attaches and I can see the files.
I then reboot the box and it boots back the the CE screen, pulses a few times and locks up indefinitely… Well after an hour if I plug the ether cable in it completes.
The Logs stop at “Can’t Find MySQL server”…
I’ve tried setting the “Wait for Network” in both states with no success.

So as a test, I can run the X97 box off a USB powerpack with the cat 6 cable attached to boot, then detach the network cable and walk the X97 outside on battery and it continues to see the MySql and files via wifi and plays fine

Am I missing something? The “Wait For network” especially states it’s for MySql, and why no timeout? Maybe it’s waiting for a DHCP address?

Any Suggestions?


Here are some basic network troubleshooting steps.

You should use wait for network option in CE addon settings:
If it’s not enough then you could try to add some sleep via

Thanks for the reply,

I have tried the Wait option both On and Off with No difference, it locks up either way until the network cable is inserted. Seconds later I can remove the cable and see my NFS shares

I think it’s failing on DNS trying to resolve the Name of the Mysql server.

I might try to switch everything to use the IP Address which means redoing the lib

If you suspect it’s DNS related. use the hosts file to hard code the MySQL servers domain name. so that device always knows it no matter what the network state is.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.