N2+ Odroid 5a dongle keeps dropping

Anyone else experiencing this? WIll be in the middle of playback, everything stops and have to reconnect.

This could be many things, so first lets deal with the simple stuff first. Go into your router and assign a “preferred” IP address to the N2+ (Usually in the DHCP Tab). Secondly check the router settings for DHCP Lease Time, it needs to be about 3600 minutes or you will have problems. Finally check for anything that could be nearby that could be interfering with the Wi-Fi signal such as cordless phones etc. Try the dongle in different USB ports on the N2+ and plugging in the dongle through a USB Male to Female cable may be an option as I personally have to use a 25cm one for the dongle for the remote because of signal interference from the magnets in my sound bar.

If you can connect via Ethernet rather than Wi-Fi I would suggest you do as its faster.

Thanks for the reply. Yep, DHCP lease time is days long. By preferred do you mean like a QoS thing, or just reserving an IP for the N2+?

Currently, I’ve only been using USB, slot 2, I’ll try others, good idea on the extender too.

Reserving an IP for the N2+ . Every router manufacturer seems to call it something different like preferred or static leases.

Two other things worth checking while your in the router is where it gets its NTP (time) data from as clock drift can really screw up Wi-Fi and that the N2+ is getting the time data from DHCP and which DNS servers are assigned I tend to assign 1.1.1.1 (Cloudflare) 8.8.8.8 (Google) and 208.67.222.222 (OpenDNS) at router level rather than rely on VirginMedia’s slow DNS.

What channel is your wifi access point defaulting to? I recall buried in a few threads which I can’t seem to find atm, (here and on the Odroid Forum), that the 5a isn’t a big fan of higher frequency channels, 44, IIRC being a particular standout. As per this thread (the only one I could find), if you have the option, set your wifi access point to use 5ghz Channel 36.

1 Like

Not a surprise, I looked at the circuit diagram the antenna in that 5a is so small its going to be incredibly prone to RFI Interference.

I always had WiFi problems, tried 3 or 4 different USB adapters, tried repeaters, tried an additional router, but the problem was that in my home there is simply too much WiFi crowding. I solved all my problems with powerline adapters. To have success with them there are 2 conditions: a good (and not too old) home electric system, and you must buy powerline adapters of the best quality. I paid mine 45 euros, and they work great. Browsing the net you’ll learn easily which is the best manufacturer.

Building construction also has a lot to do with it, the block I live in was constructed in the late 60’s out of locally made prefabricated concrete slabs and between the very substantial rebar in them and the local gravel they used containing ferrites its essentially like living in a Faraday cage with signal scattering, which is why I know a fair bit about the subject which boils down to if you want decent network coverage run ethernet cables, forget ever trying to get a radio controlled clock to work and embrace the fact your going to be the last person in your circle of friends with a landline.

Thanks for the info, I’m currently using channel 149 so perhaps I’ll see if 36 works better - I do have a neighbour currently using 44, I think.

1 Like

I have 2 other computers in my apartment that are wireless all the time with no problems - I’m not looking for better than ethernet coverage, obviously, but not dropping every 5 minutes would be nice. :wink:

I turned up an old note on the Odroid forums regarding that adaptor and power management, if you run iwconfig is the "power management enabled and if it is, does running iwconfig wlan0 power off make any difference to connection stability? If it works there are a couple of ways to make the change permanent.

Thanks, will check that tonight. It has been behaving a lot better recently since I’ve given it a permanent ip. Also my router had a guest network enabled and I’ve disabled that for 5g in case any neighbours were causing problems.

You cant disable the 5G, its needed by the implants (Joke), in other unconnected news I ditched my Linux PC and ordered a Microsoft Surface. :rofl:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice