N2+ PS3 Controller mapping Emuelec-Dolphin

Hi all,

I’ve been searching around for ages and cannot figure this one out. I have my N2+ configured nicely now and Saturn, N64, PSP, Dreamcast are all running really well.

Now how do I get a controller mapped to the dolphin emulator so I can play Gamecube?

So far I’ve added Mario Kart Double Dash to Gamecube folder which loads up fine but once the game intro begins I have no controls except for PS button+Start to exit the game.

I have found this;

[Profile]
Device = evdev/0/Sony PLAYSTATION(R)3 Controller
Buttons/A = Button 14
Buttons/B = Button 13
Buttons/X = Button 15
Buttons/Y = Button 12
Buttons/Z = Button 9
Buttons/Start = Button 3
Main Stick/Up = Axis 1-
Main Stick/Down = Axis 1+
Main Stick/Left = Axis 0-
Main Stick/Right = Axis 0+
Main Stick/Modifier = Shift_L
Main Stick/Modifier/Range = 50.000000000000000
C-Stick/Up = Axis 3-
C-Stick/Down = Axis 3+
C-Stick/Left = Axis 2+
C-Stick/Right = Axis 2-
C-Stick/Modifier = Control_L
C-Stick/Modifier/Range = 50.000000000000000
Triggers/L = Button 10
Triggers/R = Button 11
D-Pad/Up = Button 4
D-Pad/Down = Button 6
D-Pad/Left = Button 7
D-Pad/Right = Button 5

I have edited gcpadnew.ini to the above config <didn’t work
I have created a file within configs/dolphin-emu/profiles/GCPad/ps3.ini <didn’t work
I have copied the configuration from the Joypads folder and tried that on both above locations <didn’t work
I have tried 2x generic PS3 controls and a genuine PS3 & PS4 controller and I cannot get anything to recognise at all.

The last piece of the puzzle and it’s driving me mad!

Many thanks in advance!

I’ve worked it out!
replaced [profile] with [GCPad1] - I guess for additional controllers you would add [GCPad2] and then copy and paste the config after it…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice