N2+ Resolution

Hi All,

i recently bought an N2+4gb CE edition (on mmc) direct from Odroid as an upgrade to an s905x M8S box. the N2+ shipped with a clean Leia build. i updated to CE matrix Nightly (same as i was running on the s905x box) then restored a back up from s905x box. all is working fine and i noticed a good performance boost in PVR use, but i noticed on the N2+ i can only set resolution on Kodi to 2160p@30 (@60 is missing as an available option). on the S905x it replaces (and several others round the house) i am set at 2160p@60. i am using the same HDMI connected to the same Toshiba Android TV as the s905x that allowed 2160p@60.

is this expected, or is there something screwy with my N2+ install?


N2(+) supports 4k@60Hz

thanks, are there some things i an check to see why? don’t really want to start from scratch unless i have no other option…

But this is the best choice.
I need 10min to start a N2(+) from scratch

thanks, flashing fresh image is fast / straight forward enough, but then there is many addonds to install / configure, thumbs nails to sync/cache and I spent a long time customizing my skin over time, i have many menus / sub menus and all are custom with custom artwork paths, that is the bit i don’t really want to have to do again…in all starting from scratch is quite a few hours work. I use a ‘master’ back up that is restored to all the boxes round my house so all are identical from a user perspective and want to stay with that method ideally.

Check on clean install if you have this resolution.
If have and it disappear after backup restore then something wrong imported in your config, may be old manual disp_cap file.
But without logs not possible to say something
And yes, best way is clean install

OK Thanks, i will try clean install to spare SD and see if issue is stays on clean fresh image

i tried a fresh install to SD, and i see 2160p@60, and this was selected by default. i then restored a back up taken using kodi back up addon from my old s95x box that was previously set at 2160p@60. the resolution remained and i thought it had fixed the issue, however, after powering off / back on again, on boot i didn’t not get expected res (it changed to 480i) then i went to display settings and i am back to 2160p@30 as the highest. when i compare logs from boot, i can see on N+ under when it finds resolution, @60 (and @59.xx) are not listed,. where as they are on the s905x box.

Given the issue only seemed to come back after restoring back up, it suggest to me something restored is causing. i tried deleting guisettings.xml so fresh is created on boot, but didn’t help. is there some file i can check in the back up? i can get debug logs if needed. if needed from when - start up, or something more?

Update…fixed the smb problem i mentioned in this post earlier :slight_smile:


so i think maybe i fixed it. i ran the below command

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap

then in userdata i added the below lines to disp_cap file and rebooted


in kodi log at start up i now see @50 and @60 and they are available in display settings in Kodi. I have selected @60 (well actually i selected @59.94 that also now shows) no issue and it seems to persist after reboot.

did i really fix it, or have i just fudged the setting to suggest that is refresh rate when really it isnt?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.