N96 mini wifi not working in CE 20.1 ng

Just a bit of background. I purchased 3 x96mini 4 years ago for less than 15€ each. It was sold as S905W with 2Gb ram+16GB with Android 7.1. At the end of a long struggle I discovered that it had a fake memory (1GB only) and that it wasn’t a S905W but a S905L rev. d. I succeeded in installing in installing CE 9.2.8 using the generic dtb gxl_p212_1G. However the NG version had the wifi not working and so I reverted to the NON-NG version. The amlogic kernel changed (3.14 kernel) to amlogic-ng (4.9 kernel) but at that time it was OK keeping the non-ng version.

Now I installed Nexus 20.1 using NG-generic and gxl_212_1G_slowemmc dtb and everything worked but as usual the wifi is not working and I have to use the Ethernet port.

Question: Is there any possibility that additional wifi drivers might be incorporated in future version? How can I know which wifi chip is in my box? In case the driver for my wifi chip is in some other dtb is there any possibility to install it as an add-on?

Thanks

https://wiki.coreelec.org/coreelec:ce_addon_hardware#hardware
WiFi sdio speed

I tried both slow and normal in wifi without result. I even added the country without result. The wifi sees the network, it allows to choose connect it start negotiating but it ends up with Network error.

Any idea?

Well, i tried with an external dual band usb wifi receiver and it worked by just inserting it without any specific driver implementation. To be honest only the 2.4GHz band worked. It seems that it created a new wlan1, on top of the existing wlan0, that connected to my wifi network right away. The USB NIC was Realtek 8811CU Wireless LAN 802.11ac. At 11€ the USB NIC is a bargain to reuse an old box. However in the future I should invest in a more modern box (ram is a must to keep Kodi working smoothly)!

I would anyway be pleased to discover why the internal one doesn’t work in NG version. Could it be the security? In 9.2.8 non ng it worked without a fuss without changing anything in the router security (WPA2-Personal AES).