Need Help Mounting NAS

According to my WD MyCloud, the mount point for the folder I want to mount is:
nfs://192.168.1.148/nfs/Recordings
I can access this folder with my other devices (including from within Kodi on this box).

I created a file called storage-netrecordings.mount in the system.d folder with the following information:

[Unit]
Description=nfs mount script for recordings
Requires=network-online.service
After=network-online.service
Before=kodi.service

[Mount]
What=192.168.1.148:/Recordings
Where=/storage/netrecordings
Options=
Type=nfs

[Install]
WantedBy=multi-user.target

I SSH’d into the box and gave the command “systemctl enable storage-netrecordings.mount”. The box seemed to accept the command. However, no folder named netrecordings shows up in the storage folder, should it?
I tried rebooting but it still isn’t there.
Do I need to create a folder called netrecordings in the storage folder?

Thanks

Try this:
ssh root@boxip
mkdir -p /storage/netrecordings
mount -t nfs 192.168.1.144:/nfs/Recordings /storage/netrecordings -o nolock

ls -la /storage/netrecordings
Should show the files/folders from NAS

If it was successful add mount command to autostart.sh

Despite what some people may claim Samba is a more reliable way of sharing files than NFS. If a NFS share ever goes stale it s a nightmare to recreate it - and this can often happen with home servers which don’t have the protection of UPS’s.

Just my opinion.

Shoog

I´m using NAS and NFS since 2010.
No nightmare.
I´m using smb/cifs with windows computers and nfs with linux computers, raspberry and amlogic boxes.

Samba -> Windows
NFS -> UNIX/Linux

Just my opinion and my five cents.

1 Like

Thanks, that worked.
One interesting thing. I can see the netrecordings folder using WinSCP but it doesn’t show up in Windows File Explorer.

Windows uses samba.
You must configure it in samba config file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.