Need suggestion on how to revive a dead MXQ Pro 4K (S905)

A friend recently gave me a dead MXQ Pro 4K (S905) with 1/8 GB RAM/eMMC storage. He told me the device was running the last version of LE, i.e. v8.2.3.1 (?), off a USB memory stick. What happened was his device ran very sluggishly, i.e. unresponsive to remote control, and suddenly an electricity outage happened. After the electricity came back, his MXQ Pro 4K is flat dead, i.e. black screen. I tried the toothpick attempts with a USB memory stick on every USB ports to no avail. I also tried using my LE- on an SD card to no avail. At this moment, I ran out of ideas. I sure will appreciate some helps here. Thanks.

If you have “black screen” on both video outputs (HDMI and AV), I’m afraid you have to get a new box. This one seems to be fried…

I reckon so, unfortunately. BTW, the LED still lights up in blue color.

Did you try/test AV video output? Maybe only HDMI is misbehaving…

Amlogic Burning Tool
Flash Android for this Box.
Blue light is a good sign.

Is Amlogic Burning Tool a Windows or Linux util? I only have some Linux desktop computers with adb. Will that work and how?

Windows ; You have to try this as a last resort.

Looks like that will be my last resort. However, we ONLY use Linux OS here, i.e. no windows nor mac. If anyone can tell me how to do this on a Linux desktop computer with ADB, I certainly will appreciate that.

there is a linux version available here, adb is not related in anyway to using the Amlogic burning tool :confused:

the instructions are on the github page, other than that you need a USB-A to USB-A lead, it may be less headache to just buy a new box, they are cheap enough

Thank you Adam.

Well, it is always good to be able to recover the unit, instead of throwing it into a trash can.

You can also install windows in a VM on Linux.

I tried not to go this route.