Netflix 0.13.10 Crash when playing video 8.90.4

Anyone else having issues with Netflix not playing videos on the new 8.90.4?

Have tried uninstalling and then doing fresh install and the video seems to start to play and then just goes to the folders screen.

Have you installed inputstream.adaptive?

Kodi 18 nightlybuild
Inputstream.adaptive >=v2.0.0 (should be included in your Kodi 18 installation)
Libwidevine >= (for non Android devices)
Cryptdome python library (for Linux systems, install using pip install --user pycryptodomex as the user that will run Kodi)

Yep enabled from Coreelec addons > Video Input stream

Provide logs then we don’t have a crystal ball

I had the same issue. Changed skin to Chroma and working fine now. Don’t ask me why I have no idea.

Was more seeing if others were having issues as logs didn’t provide anything. The theme swapped worked.

I’ve also had a crash with the same version of the Netflix plugin and 8.90.4 on my C2. Crashlog uploaded at

You either need to update the add-on or post a bug report on the add-ons issue tracker, we don’t maintain the Netflix add-on.

Is it possible in the future Coreelec will not use be using the latest alphas etc.

Or have images with more stable Kodi versions?

Ofcourse, that is the plan.

That’d be great.

I know 18 is an alpha and they are fixing things while breaking others. You do a lot of really great work improving the OS and if there was a decently stable version of Kodi to use for now it’d be amazing!