Netflix Add-On Help

Hi guys,
Is there a way to fix unwatchable stuttering videos in this Netflix Add-On?
https://forum.kodi.tv/showthread.php?tid=329767&pid=2738248#pid2738248
Thanks in advance.

I’m using a Minix UH-9 box.

Software decoding on S912 isn’t working properly.
It’s lacking proper gpu drivers.
Software decoding on s905/x is working fine.
I hope some day @anon88919003 will merge wrxtasy’s pr with an updated gpu driver and test my mecool pro L for the netflix addon.
Everything is work fine except netflix addon on my S912

1 Like

Thanks for the response. What do you say @anon88919003 - Can you help?

How does Netflix perform in Android?

The updated GPU driver makes very little difference and in fact introduces regressions, we have already included the subtitle fix for the next release though.

The Netflix H/W decoding issue is unlikely to get fixed any time soon.

It is not our job to fix developers add-on’s and what your asking is like asking Apple to fix a problem with an app on it’s App store… it just would never happen, we provide the O/S, you provide the addon’s, if there is problems with them then you need to take it up with the developer.

Set the max resolution to 720p and you should have no issues.

On a final note, I do not speak for the whole team.

1 Like

Does 720p still stutters? don’t bother with 1080p as you can’t do anything about it no matter what release you install.

Atleast on my Mecool KIII Pro it doesn’t make much of a difference if I change from 1080p to 720p, the stuttering is unbearable.

I don’t know if I’m running into the subtitle stuttering bug rather than the S912 GPU driver issue though. (Or does the subtitle issue even impact video)

Hello.Suddenly after 9.2.3 update, Netflix streams only at 960x540p.Any solution?

No, it has nothing to do with CE.9.2.3 update! It’s Netflix restriction with no fix at the moment…

Ohh.It happens to all and only on Kodi or general??

At the moment it happens on all Linux based systems that use Chrome to extract and use Widevine L3 decryption module (libwidevinecdm.so).
Nothing to do with CoreElec or Kodi versions, nor with Netflix addon…

Thanks buddy.

Netflix is giving a "keyerror’ msg and refusing to load. The problem is affecting many people and is discussed on the kodi forum.

Ran into that yesterday and fixed it today, Netflix add-on broken

1 Like

Solved my Netflix error as well.

It solved my Netflix error as well :smiley:

You can find the fix for 1080p resolution in the CadtagnaIT GitHub original thread.

Update to new NF.1.5.1 version, and all Netflix original media should work in 1080p again on Arm devices.
It works OK on my Odroid N2, and also noticed that streams with high bitrate are no longer throttled, I noticed that high bitrate streams spike now up to 25-28Mbits on my N2, same as before Covid-19 situation…

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice