Netflix Installation - How Do I Get Netfllix Working?

Ok… any ideas what’s wrong then?

None, ask here

Repo is dead:
ERROR: CCurlFile::Stat - Failed: Couldn’t connect to server(7) for https://johtru.com/repo/repo_files/plugin.video.netflix/plugin.video.netflix-0.13.22.zip

Wiki is dead.

You are using an old repo version…
Use new repo with new NF version 0.14.6_20190708

3 Likes

Well again Netflix has stopped working. It throws error after boot, some kind of parse error while launching bakground services. That’s since yesterday

For Netflix addon help go here

I reinstalled addon, now it works again. However, it keeps throwing nonsense parse errors from time to time, for example playback does not start and error thrown, second try succesfull

What version of CoreElec are you using ?
What version of NF addon ? (should use v.0.15.2)
What version of inputstream.adaptive ? (should use v.2.3.22.2)
What version of inputstream. helper ? (should use v.0.4.2)
All these can influence NF addon behaviour.

With inputstream.helper 0.4.2 you can reinstall WideVine decryption library to see if that will fix your errors…

1 Like

hi.
After install Netflix from CastagnaIT repository
I got such info about installation

is this normal 3.1GiB?

Yes, perfectly normal.

1 Like

is not available only libwidevinecdm.so 10mb not 3GiB

Yes, extract from chrome os need 3 GB, but dont worry, just temporally. After that you will come back that space, No problem

2 Likes

Hi,
3.1 gb chromeOs img download didn’t finish in 2 hours. it has started normally coming to end but not completed. Sd cart is 16gb
Any idea or different add-on suggestions?

Edit: no problem in my second try
Thx

This one works great for me at this moment :slightly_smiling_face:
CoreELEC, latest version on my “Le Potato”

I have the same issue.

Tried installing from the repo and directly from zip.

Device: Minix U9-H
CoreELEC (official): 9.2.2
Kodi 18.6

My workaround is to switch off InputStreamHelper, but then I get 1080P max only as its on software decoder.

https://pastebin.com/7y487npn

Please help how I can get past the Widevine CDM decode error: “UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc5 in position 29: ordinal not in range(128)”.

Seems like my download completes successfully and then the extract fails with the error above…

CoreELEC:~ # ls -lah /storage/.kodi/userdata/addon_data/script.module.inputstreamhelper/temp
total 974M
drwxr-xr-x 3 root root 1.0K May 3 16:50 .
drwxr-xr-x 4 root root 1.0K May 3 15:48 …
-rw-r–r-- 1 root root 4.1M May 3 15:48 4.10.1582.2-mac-x64.zip
-rw-r–r-- 1 root root 970.1M May 3 15:54 chromeos_12739.111.1_bob_recovery_stable-channel_mp.bin.zip
drwxr-xr-x 2 root root 1.0K May 3 16:07 mnt
CoreELEC:~ #

Tested and verified:
Profiles work
Atmos works

Not working:
4k not working

Please help

No 4k netflix using netflix app running CE

1 Like

Thanks @Tim_Taylor, do you think its OK to run without InputtreamHelper? Widevine CDM install fails as per my log

I know You could watch max 1080, because the limitation of software decoding.

If You own a 4k TV, You could use netflix app from TV

True and that works, but then my Atmos passthrough does not work, as my TV does not pass the audio unencoded.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice