Netflix Installation - How Do I Get Netfllix Working?

I have searched around the Corelec posts to try to find a way to get Netflix installed/working, but I haven’t been able to find anything to really help get this done. What do I need to do to install and get Netflix running?
I will be happy to create a How to once I am able to get this working.

Just follow the link:

By the way: I cannot make this addon work on 8.90.3 so I went back to 8.90.2.

1 Like

it works with 8.90.3, at least on KVIm

You need the correct widevine files.
You can get them from Sandmanns Amazon Test Plugin / Inputstream Helper.

I tried to make it work. The netflix addon downloaded the necessary widevine files, but when I started it, I got an error message. Could you please help me what to do with this “Sandmanns Amazon Test Plugin / Inputstream Helper”?

Please read before opening another thread.

I have searched about to find a write-up/How-to install Netflix on Coreelec, but have had no luck.

Would some kindly soul point me in the correct direction please?


Check this page -
Install Netflix repository from there, then install Neflix addon. It will download Google Chrome Recovery OS image and extract widevine. Maybe you’ll need to enable (or install) InputStream Adaptive addon (My addons->VideoPlayer InputStream), reboot your box and you’re good to go.
Latest Netflix addon is 0.3.17 and I can confirm it is working on CoreELEC 8.95.5.
Hope it helps :slight_smile:

Thank you.


Installed and working using new First Month Free account with Netflix.
Now I will be able to see what all the fuss is about :slight_smile:

Thanks again :wink:

What can i do when the Stream works but it feels a bit “laggy”. It seems that audio/video is a bit out-of-sync.

You can limit inputstream adaptive to 720p for encrypted streams.

I cant get this addon to work , on 9.0.1 , addon enabled , widevine installed ( it downloaded and installed google chrome recovery OS image ), enabled “VideoPlayer InputStream” from CoreELEC addons, I can open netflix choose a video , kodi tries to play it for a couple of secs then then spinner stops ?

This addon seems to have problems with some special chars in the password.
Try to choose a different password without too special characters.

Anyone had any luck lately with Netflix plugin?
Tried the other day, latest Coreelec 9.0.2 and latest plugin from
Login doesn’t work. Tried several workarounds but nothing helps.
Funny thing is, every time i start Netflix it states wrong credentials and the same second i get email from Netflix about a new login :slight_smile:
Tried simplifying the password, doesn’t work.

1 Like

Mine is working, I use this repo

In Kodi forum you have also the links to latest builds.

1 Like

All new Netflix versions are on this link:

0.14.5 version has resolved credentials issue…

1 Like


You’re great, thanks a lot …

Best regards…

1 Like

Question: where this plugin comes from? I see that in the official GitHUB repo ( the development is stuck at 0.13.x and nothing really happened since March

It is the beta 0.14 github repo

As I see it there are several developers for NF plugin with different repositories:
“” (libdev + jojo + asciidisco devs)
“” (castagnait dev)

Latest plugin versions are found here “”

1 Like

I think Castaignat picked up the work and continued somehow. In the Kodi forum thread that’s the one they’re pointing to.