Netflix resolution problem

Anybody else with Netflix playing with max 576p resolution as of tonight?
Updated my inputstream.adaptive to on CE19.3 but no change?
Did not see anybody else with this problem on Kodi/NF addon thread, nor on githhub…

I noticed it yesterday and already contacted CastagnaIT. He’s aware of the problem but no solution for now. There have been some changes in Netflix services (that was why an update to the addon was launched this weekend, with some fixes) so, as usual, we have to wait and see how it turns out.

PS - or open an issue on GitHub, I also checked and didn’t see any complaint in there or Kodi forum.

Can you try with CE.9.2.8/Leia, since I read that RPi 4s on Leia still have 1080p?

Yes, just tried Leia and I can get 1080p

I have the sam problem on my Corelec Matrix version. I will look for the sd card with Leia to confirm that it works with older version.

There is, as of today, a developer test build that can be tested on Matrix.

Thanks, now worked as FHD.
Device Beelink GT King Pro CE Matrix and CE Nexus.

1 Like

Why don’t you use h264 decoder instead of vp9? With h264 you get a better picture but it needs higher internet speed.

It doesn’t work with Beelink GT1 mini2. By the way what more adjusts are needed? Just install it and run or something else could be done?

Did you follow exactly the instructions? workaround

1 Like
Open addon Expert settings
Set Version 1 to MSL manifest version setting
Let me know if there are side effects

Step 1:

Download and install

Step 2:

Enable the old Manifest to get HD:

  • Invoke Netflix Add-on Settings
  • Choose Expert
  • Scroll down to Advanced Add-on Configuration
  • Set MSL manifest version => Version 1

The Netflix addon has now been updated with this workaround. Everyone can just update and follow the instructions on how to enable the old manifest.

The new version has been issued

That helped. Now it it’s Full HD. Thank you.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.