Network dead after 9.2.3 update [SOLVED]

ODroid N2 CoreELEC, which was working well with Kodi and NextPVR Client. I just update from 9.2.2 today and now the wired network connection is dead. It’s configured for a static IP address, which I confirmed. I think the IP address may have been lost in a previous update, but don’t recall for sure. I can’t ping it from any of my 3 computers. Everything else is up network-wise and I can ping an RPi that’s on the same switch. I powered it down for a minute and cold-booted, still no joy. It’s been a few days since I used this N2 but I SSHed into it last week to check some settings.

Please check connection settings in CE settings if the network mask is and fix it like to

Thanks. I did check the IPv4 settings as I swear I lost those on a previous upgrade. They are all good, including the subnet mask. Maybe I’ll try switching to DHCP and see if that connects.

1 Like

Problem solved. I looked at the “IPv4” settings to confirm them, but not the “Connection” settings. The “connect automatically” was turned off, it must have been turned off with the upgrade.